2017 -金马五校程序设计竞赛-A - STEED Cards

Description
Corn does not participate the STEED contest, but he is interested in the word “STEED”. So, Corn writes all permutations of the word “STEED” on different cards and gets 60 cards finally.

Corn sorts these cards in lexicographical order, and marks them from 1 to 60.

Now, Corn gives you a integer N (1 ≤ N ≤ 60), could you tell him the word on the Nth card?

Input
There are multiple test cases (no more than 60).
For each test case, there is one integer N (1 ≤ N ≤ 60) in a line.

Output
For each test case, you should output one line with the word on the Nth card.
Sample Input

1
2
3
4
47
48
49

Sample Output

DEEST
DEETS
DESET
DESTE
STEDE
STEED
TDEES

思路:将全排列的字符串放在二位数组里打表,
代码:

#include <iostream>
#include<cstdio>
#include <algorithm>    /// next_permutation, sort
using namespace std;
int main () {
  int  myints[] = {83,84,69,69,68};
  sort (myints,myints+5);
  char b[100][5];
  int i=0;
  do {
        b[i][0]=myints[0];
        b[i][1]=myints[1];
        b[i][2]=myints[2];
        b[i][3]=myints[3];
        b[i][4]=myints[4];
        b[i][5]='\0';
       /// cout<<b[i][0]<<b[i][1]<<b[i][2]<<b[i][3]<<b[i][4]<<endl;
       /// printf("%s\n",b[i]);
        i++;
  } while ( next_permutation(myints,myints+5) );///获取下一个较大字典序排列
  ///printf("%d\n",i);
  int n;
  while(cin>>n)
  {
      cout<<b[n-1][0]<<b[n-1][1]<<b[n-1][2]<<b[n-1][3]<<b[n-1][4]<<endl;
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值