POJ2406-暴搜,kmp

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 25491 Accepted: 10694

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目大意是给你一串字符串,然后你在里头找出最小的循环节,并输出循环次数。比如abcd,循环节就是本身,循环1次。而aaaa循环节是a,循环了4次,ababab循环节是ab,循环了3次

这道题其实暴搜直接就过了

11371876TSERROF2406Accepted4784K1891MSC++427B2013-03-20 14:07:58
#include<iostream>
#include <algorithm>
#include <string>
using namespace std;
int main()
{
	string s;
	while (cin>>s && s!=".")
	{
		unsigned int n=1;
		for(n=1;n<=s.size();++n)
		{
			if( s.size()%n ) continue;
			string substr=s.substr(0,n);
			string temp=substr;
			for(unsigned t=1;t<s.size()/n;++t)
				substr.append(temp);
			if(substr==s)
				break;
		}
		cout<<s.size()/n<<endl;
	}
	return 0;
}

不过貌似很慢,不过可以用kmp的思想来做,稍后补上


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值