poj 1815 Friendship(最小割,求割集)

Friendship
Time Limit: 2000MS Memory Limit: 20000K
Total Submissions: 10532 Accepted: 2919

Description

In modern society, each person has his own friends. Since all the people are very busy, they communicate with each other only by phone. You can assume that people A can keep in touch with people B, only if 
1. A knows B's phone number, or 
2. A knows people C's phone number and C can keep in touch with B. 
It's assured that if people A knows people B's number, B will also know A's number. 

Sometimes, someone may meet something bad which makes him lose touch with all the others. For example, he may lose his phone number book and change his phone number at the same time. 

In this problem, you will know the relations between every two among N people. To make it easy, we number these N people by 1,2,...,N. Given two special people with the number S and T, when some people meet bad things, S may lose touch with T. Your job is to compute the minimal number of people that can make this situation happen. It is supposed that bad thing will never happen on S or T. 

Input

The first line of the input contains three integers N (2<=N<=200), S and T ( 1 <= S, T <= N , and S is not equal to T).Each of the following N lines contains N integers. If i knows j's number, then the j-th number in the (i+1)-th line will be 1, otherwise the number will be 0. 

You can assume that the number of 1s will not exceed 5000 in the input. 

Output

If there is no way to make A lose touch with B, print "NO ANSWER!" in a single line. Otherwise, the first line contains a single number t, which is the minimal number you have got, and if t is not zero, the second line is needed, which contains t integers in ascending order that indicate the number of people who meet bad things. The integers are separated by a single space. 

If there is more than one solution, we give every solution a score, and output the solution with the minimal score. We can compute the score of a solution in the following way: assume a solution is A1, A2, ..., At (1 <= A1 < A2 <...< At <=N ), the score will be (A1-1)*N^t+(A2-1)*N^(t-1)+...+(At-1)*N. The input will assure that there won't be two solutions with the minimal score. 

Sample Input

3 1 3
1 1 0
1 1 1
0 1 1

Sample Output

1
2

Source




这个题解很详细,顺便补充一点,求割集时当枚举到一个点,假设其入点为v,出点为v',那么跑完最大流后若这一条边是满流边,那么这个点才有可能是属于割集,而且不需要将这一点与其他点的所有联系断去,只需要将v到v'这条边断去就可以了。

顺便提出一个易错点满流边不一定属于割集,割集中的边一定是满流边!


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
const int MAXN=400+10;
const int MAXM=MAXN*MAXN;
const int INF=0x3f3f3f3f;
int g[MAXN][MAXN],mg[MAXN][MAXN];
bool flag[MAXN];
struct Node
{
    int from,to,next;
    int cap;
}edge[MAXM];
int tol;
int n,s,t;
int dep[MAXN];//dep为点的层次
int head[MAXN];

void init()
{
    tol=0;
    memset(head,-1,sizeof(head));  
}
void addedge(int u,int v,int w)//第一条边下标必须为偶数
{
    edge[tol].from=u;
    edge[tol].to=v;
    edge[tol].cap=w;
    edge[tol].next=head[u];
    head[u]=tol++;
    edge[tol].from=v;
    edge[tol].to=u;
    edge[tol].cap=0;
    edge[tol].next=head[v];
    head[v]=tol++;
}

int BFS(int start,int end)
{
    int que[MAXN];
    int front,rear;
    front=rear=0;
    memset(dep,-1,sizeof(dep));
    que[rear++]=start;
    dep[start]=0;
    while(front!=rear)
    {
        int u=que[front++];
        if(front==MAXN)front=0;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(edge[i].cap>0&&dep[v]==-1)
            {
                dep[v]=dep[u]+1;
                que[rear++]=v;
                if(rear>=MAXN)rear=0;
                if(v==end)return 1;
            }
        }
    }
    return 0;
}
int dinic(int start,int end)
{
    int res=0;
    int top;
    int stack[MAXN];//stack为栈,存储当前增广路
    int cur[MAXN];//存储当前点的后继
    while(BFS(start,end))
    {
        memcpy(cur,head,sizeof(head));
        int u=start;
        top=0;
        while(1)
        {
            if(u==end)
            {
                int min=INF;
                int loc;
                for(int i=0;i<top;i++)
                  if(min>edge[stack[i]].cap)
                  {
                      min=edge[stack[i]].cap;
                      loc=i;
                  }
                for(int i=0;i<top;i++)
                {
                    edge[stack[i]].cap-=min;
                    edge[stack[i]^1].cap+=min;
                }
                res+=min;
                top=loc;
                u=edge[stack[top]].from;
            }
            for(int i=cur[u];i!=-1;cur[u]=i=edge[i].next)
              if(edge[i].cap!=0&&dep[u]+1==dep[edge[i].to])
                 break;
            if(cur[u]!=-1)
            {
                stack[top++]=cur[u];
                u=edge[cur[u]].to;
            }
            else
            {
                if(top==0)break;
                dep[u]=-1;
                u=edge[stack[--top]].from;
            }
        }
    }
    return res;
}
void build()
{
	init();
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			if(i==j) continue;
			if(g[i][j]) addedge(i+n,j,INF);
		}
	}
	for(int i=1;i<=n;i++)
	{
		if(i!=s&&i!=t) addedge(i,i+n,1);
		else addedge(i,i+n,INF);
	}
}

int main()
{
	while(~scanf("%d%d%d",&n,&s,&t))
	{
		memset(g,0,sizeof(g));
		memset(mg,0,sizeof(mg));
		memset(flag,false,sizeof(flag));
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&g[i][j]);
				//mg[i][j]=g[i][j];
			}
		}
		build();
		int ans=dinic(s,t+n);
		if(ans>=INF) puts("NO ANSWER!");
		else 
		{
			int mans=ans;
			printf("%d\n",ans);
			if(!ans) continue;
			for(int i=1;i<=n;i++)
			{
				if(i==s||i==t) continue;
				for(int j=1;j<=n;j++)
				{
					for(int k=1;k<=n;k++)
					{
						mg[j][k]=g[j][k];
						if(j==i||k==i)
						g[j][k]=0;
					}
				}
				build();
				int re=dinic(s,t+n);
				if(re<ans) ans--,flag[i]=true;
				else
				{
					for(int j=1;j<=n;j++)
					{
						for(int k=1;k<=n;k++)
						g[j][k]=mg[j][k];    
					}
				}
				if(!ans) break;
			}
			int cnt=0;
			for(int i=1;i<=n;i++)
			{
				if(flag[i]) 
				{
					cnt++;
					printf("%d%c",i,cnt==mans?'\n':' ');
				}
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值