PAT 1004. Counting Leaves (30)

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

思路: 由于不确定一个node具体会有多少个child, 因此用"first child, next sibling"的方式来构建树. 将每个节点的地址都放在一个列表里, 这样能比较快速的寻找到节点, 并建立联系. 同时在结构体中增加一个变量叫做nochild, 当某个节点没有child的时候这个变量的值为1. 在执行递归函数find时通过对nochild变量的判定, 就能比较快速的找到所需节点, 再根据其所在的level对count[level]递增. 最后按序输出count[]数组中的数据即可.


#include <iostream>
#include <cstring>
using namespace std;
struct node
{
	int nochild;
	node* first_child;
	node* next_sibling;	
};
int count[100];
int Max;
void find(node *current,int level) 
{
	if(level > Max)
		Max = level;
	if(current->nochild == 1)	
		count[level]++;
	else
		find(current->first_child,level+1);
	if(current->next_sibling!=NULL)
		find(current->next_sibling,level);
	return;
}
int main(void)
{
	int i,j,k,l,N,M,num;
	node *temp;
	cin >> N >> M;
	node* array_node[N+1];
	memset(count,0,sizeof(count));
	for(i = 1; i < N+1; i++)
	{
		array_node[i] = new node;
		array_node[i]->nochild = 1;
	}
	for(i = 0; i < M; i++)
	{
		cin >> j >> num >> l;
		array_node[j]->first_child = array_node[l];
		array_node[j]->nochild = 0;
		temp = array_node[j]->first_child;
		for(k = 1; k < num; k++)
		{
			cin >> l;
			temp->next_sibling = array_node[l];
			temp = temp->next_sibling;
		}
	}
	Max = 1;
	find(array_node[1],Max);	
	for(i = 1; i < Max; i++)
		cout<<count[i]<<" ";
	cout<<count[Max];
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值