PAT 1053. Path of Equal Weight (30)

1053. Path of Equal Weight (30)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

这道题是树的遍历问题。用DFS就可以解决。要注意的是要对DFS后得到的所有结果按照降序排列再输出。代码如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <set>
#include <map>
using namespace std;
int weight[100];
int isnotLeaf[100];
map<int,set<int> > relation;
vector<int> result;
vector<vector<int> > answer;
bool isempty=false;
int sum=0,S;
void dfs(int x)
{
	result.push_back(weight[x]);
	sum+=weight[x];
	if(sum==S)
	{
		if(isnotLeaf[x]==0)
			answer.push_back(result);
	}
	else if(sum<S)
	{
		set<int>::iterator it;
		for(it=relation[x].begin();it!=relation[x].end();it++)
			dfs(*it);
	}
	sum-=weight[x];
	result.pop_back();
	return;
}
bool cmp(vector<int> a,vector<int> b)
{
	int asize=a.size();
	int bsize=b.size();
	int min=(asize,bsize);
	for(int i=0;i<min;i++)
	{
		if(a[i]==b[i])
			continue;
		else
			return a[i]>b[i];
	}
	if(min==asize)
		return false;
	else
		return true;
}
int main()
{
	int N,M,i;
	cin>>N>>M>>S;
	memset(weight,0,sizeof(weight));
	memset(isnotLeaf,0,sizeof(isnotLeaf));
	for(i=0;i<N;i++)
		cin>>weight[i];
	for(i=0;i<M;i++)
	{
		int parent,num,child;
		cin>>parent>>num;
		isnotLeaf[parent]=1;
		for(int j=0;j<num;j++)
		{
			cin>>child;
			if(relation.count(parent)<=0)
			{
				set<int> temp;
				temp.insert(child);
				relation[parent]=temp;
			}
			else
				relation[parent].insert(child);
		}
	}
	dfs(0);
	int size=answer.size();
	sort(answer.begin(),answer.end(),cmp);
	vector<int>::iterator it;
	for(i=0;i<size;i++)
	{
		int msize=answer[i].size();
		for(int j=0;j<msize-1;j++)
			cout<<answer[i][j]<<" ";
		cout<<answer[i][msize-1]<<endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值