PAT 1060. Are They Equal (25)

1060. Are They Equal (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3

这道题简直就是坑,各种数值的格式处理题目都不说清楚,总是有两个点过不了,于是只好自己一遍遍调试一遍遍猜,去迎合题意。弄了好久终于是过了。总结一下,主要要注意的是以下两个点:

1) 不管N是几,所有的0都是一样的,且输出位数根据N来变。例如 3 0.0000 0 的输出结果是 YES 0.000*10^0

2)题目中有可能会给出0005000.03 这种开头就带0的数,一定要处理掉。

一次次修改的过程中代码已经弄的很凌乱了:

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
string chop(string x,int N)
{
	int size=x.size();
	int pos=x.find('.');
	int exp;
	string before,after;
	if(pos>=0)
	{
		before=x.substr(0,pos);
		after=x.substr(pos+1);
	}
	else
	{
		before=x;
		after="";
	}
	string result="0.";
	string temp;
	int tc=atoi(before.c_str());
	if(tc!=0)
	{
		int tempc=0;
		for(int i=0;i<before.size();i++)
		{
			if(before[i]=='0')
				tempc++;
			else
				break;
		}
		if(tempc>0)
			before=before.substr(tempc);
		exp=before.size();
		if(exp>=N)
			result+=before.substr(0,N);
		else
		{
			result+=before;
			result+=after.substr(0,N-exp);
		}
		result+="*10^";
		char buf[101];
		sprintf(buf,"%d",exp);
		temp=buf;
		result+=temp;
		return result;
	}
	else
	{
		int wtf=atoi(after.c_str());
		if(wtf==0)
		{
			result="0.";
			for(int i=0;i<N;i++)
				result.push_back('0');
			result+="*10^0";
			return result;
		}
		int count=0;
		for(int i=0;i<after.size();i++)
		{
			if(after[i]=='0')
				count++;
			else
				break;
		}
		if(count==after.size())
			count=0;
		result+=after.substr(count);
		int size=result.size()-2;
		if(size>N)
			result=result.substr(0,N+2);
		if(count>0)
			result+="*10^-";
		else
			result+="*10^";
		char buf[101];
		sprintf(buf,"%d",count);
		temp=buf;
		result+=temp;
		return result;
	}
}
int main()
{
	int N,i;
	string a,b;
	cin>>N>>a>>b;
	if(N==0)
	{
		cout<<"YES 0.*10^0";
		return 0;
	}
	string ra=chop(a,N);
	string rb=chop(b,N);
	if(ra==rb)
		cout<<"YES "<<ra;
	else
		cout<<"NO "<<ra<<" "<<rb;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值