【HDU 1541】Stars(树状数组)

3 篇文章 0 订阅


Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9286    Accepted Submission(s): 3704


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 
题目大意:输入星星的坐标,求每个星星坐下方有多少个,按个数输出结果
思路:输入的坐标是按顺序的,只要求出比当前横坐标小的共有多少个就行了。按横坐标建立树状数组,依次求和。注意下标是从0开始,需要加1,树状数组下标为0会T。
           初学树状数组,真是一个神奇的方法。这是第一个用树状数组写的题 hahaha。

#include<bits/stdc++.h>
#define manx 33000
using namespace std;
int n;
int c[manx];
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int num)
{
    while(x<=32001){  //注意不是n
        c[x]+=num;
        x+=lowbit(x);
    }
}
int Sum(int x)
{
    int sum=0;
    while(x){
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
    int x,y;
    int a[manx];
    while(~scanf("%d",&n)){
        memset(c,0,sizeof(c));
        memset(a,0,sizeof(a));
        for (int i=1; i<=n; i++){
            scanf("%d%d",&x,&y);
            int sum=Sum(x+1); 
            a[sum]++;
            add(x+1,1);  //下标不为0
        }
        for (int i=0; i<n; i++)
            printf("%d\n",a[i]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值