HDU6077Time To Get Up(模拟)

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 307    Accepted Submission(s): 248


Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38
 
题意:给你时间的图像输出他的数
思路:观察特征直接暴力模拟
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <math.h>
using namespace std;
char a[10][30];
void judge(int n)
{
    int cot=0;
    for(int i=0+n;i<=3+n;i++)
            for(int j=0;j<7;j++)
            if(a[j][i]=='X')
            cot++;
        if(cot==4)
            printf("1");
        else if(cot==6)
            printf("7");
        else if(cot==8)
            printf("4");
        else if(cot==14)
            printf("8");
        else if(cot==12)
        {
            if(a[3][1+n]=='.'&&a[3][2+n]=='.')
                printf("0");
            else if(a[1][3+n]=='X'&&a[2][3+n]=='X')
                printf("9");
            else
                printf("6");
        }
        else if(cot==10)
        {
            if(a[1][3+n]=='X'&&a[5][3+n]=='.')
            printf("2");
            else if(a[1][3+n]=='X'&&a[5][3+n])
                printf("3");
            else printf("5");
        }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0;i<7;i++)
            scanf("%s",a[i]);
        judge(0);
        judge(5);
        printf(":");
        judge(12);
        judge(17);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值