PAT甲级 1002 A+B for Polynomials

2 篇文章 0 订阅
2 篇文章 0 订阅

这个题我一直没发现错误,只对了第一个样例,我看了好几遍都没有发现哪里错了,最后发现float d[1001]忘了初始化定义,小伙伴们不要像我这样粗心奥。

题目:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

题意:每行包含一个测试案例,每个案例包含两行,每行包括一个多项式的信息:K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​,k是非零的数在多项式中,‎A、B分别是指数与系数,这是给的1≤K≤10,0≤nK​​<⋯<n​2​​<n​1​​≤100 0,对于每个测试案例,您应该输出总和之AB在一行中,与输入格式相同。请注意,每行末尾不得有额外的空间。请精确到1小数点的地方。

散装英语,新手上路,轻喷!!!

输入样例

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出样例

3 2 1.5 1 2.9 0 3.2

代码段

#include <iostream>
using namespace std;
int main(){
	int a,b,sum=0;
	float d[1001]={0},c;
	for(int i=0;i<2;i++){
		cin>>a;
		for(int j=0;j<a;j++){
			cin>>b>>c;
			d[b]=d[b]+c;
		}
	}
	for(int i=0;i<1001;i++){
		if(d[i]!=0) sum++;
	}
	cout<<sum;
	for(int i=1000;i>=0;i--){
		if(d[i]!=0)
		printf(" %d %.1f",i,d[i]);
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值