JOJ ACM 1237

1237

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

 

Write a program to read a character string and determine its smallest period.

Input

A single character string of up to 80 non-blank characters.

Output

An integer denoting the smallest period of the input string.

Sample Input

 

HoHoHo

Sample Output

 

2
代码:
#include<stdio.h>
#include<string.h>
int main()
{
 char str[80];
 int len,period,j;
 while(scanf("%s",str)!=EOF)
 {
  period=1;
  len = strlen(str);
  while(period!=len)
  {
   if(len%period!=0)
   {
    period++;
    continue;
   }
   for(j=period;j<len;j++)
   {
    if(str[j]!=str[j%period])
      break;
   }
   if(j==len)
   {
    printf("%d/n",period);
    break;
   }
   period++;
  }
  if(period==len)
  {
         printf("%d/n",period);
  }
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值