HDU 4727 The Number Off of FFF 2013年成都全国邀请赛原题

题意很简单:就是给你一串连续的数字,他应该是递增的后面比前面大一如果出现了不是大于一的情况输出这个数的位置。标准的水题,但是很坑的是,没有写x=1就会wa、、结果错了好几遍啊、、sad啊、、神坑啊、、、因为每组数据都将有一个错误如果之后的都没有错,就说明第一个错了、、所以就要输出1。

The Number Off of FFF

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 186    Accepted Submission(s): 91


Problem Description
X soldiers from the famous " *FFF* army" is standing in a line, from left to right.
You, as the captain of  *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input
The rst line has a number T (T <= 10) , indicating the number of test cases.
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10 5)
It guaranteed that there is exactly one soldier who has made the mistake.
 

Output
For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input
  
  
2 3 1 2 4 3 1001 1002 1004
 

Sample Output
  
  
Case #1: 3 Case #2: 3
 

Source

#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

int main()
{
    int i, t, n, x, f[101000], case1 = 1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 1; i <= n; i++)
            scanf("%d",&f[i]);
        x = 1;
        for(i = 2; i <= n; i++)
            if(f[i]-f[i-1] != 1)
            {
                x = i;
                break;
            }
        printf("Case #%d: %d\n",case1++, x);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值