HDU4727:The Number Off of FFF

Problem Description
X soldiers from the famous " *FFF*  army" is standing in a line, from left to right.
You, as the captain of   *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input
The rst line has a number T (T <= 10) , indicating the number of test cases.
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10 5)
It guaranteed that there is exactly one soldier who has made the mistake.
 

Output
For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input
  
  
2 3 1 2 4 3 1001 1002 1004
 

Sample Output
  
  
Case #1: 3 Case #2: 3
 


 

题意:队列里所有人进行报数,要找出报错的那个人

思路:其实是很水的题,只要找出序列中与钱一个人的数字差不是1的人即可,但是要注意的是这些人是从一个队列中间截取下来的,所以很有可能第一个人就报错了,一开始没有考虑这种状况所以出错了

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int num[100005];

int main()
{
    int T,cas = 1,n,i,x,flag;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        x = -1;
        flag = -1;
        for(i = 0; i<n; i++)
            scanf("%d",&num[i]);
        for(i = 1;i<n;i++)
        {
            if(num[i]-num[i-1]!=1)
            flag = i+1;
        }
        if(flag==-1)
        flag = 1;
        printf("Case #%d: ",cas++);
        printf("%d\n",flag);
    }

    return 0;
}


 

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值