贪心-G

题目描述

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

输入

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

输出

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
这个题和之前老师将的选节目问题很相似,我以为只需要将房间的上下限按上限升序就可以ac,但忽略了几点问题,首先这个房间的排列是一边奇数号一遍偶数号,再者就是这个桌子是可以同时移动的,例如,有3组房间,一二组相互影响,二三组相互影响,如果单纯按选作业的思想,答案会多10。解决方法:先排序,定义一个判断数组,再定义一个a,用个二重循环。每个一重循环结束后时间加10,在二重循环中,如果当前下限大于或等于上一个的上限(a),则a=当前上限,判断数组变为true,否则,a不变。可以看出,这种方法是不如按桌子的移动轨迹的方法更优的。

用桌子的移动轨迹解决问题的代码

#include <iostream>
#include <algorithm>
#include <set>
using namespace std;
struct t
{ int price;
  int day;

}t1[10010];
/*bool cmp(t t1,t t2)
{
     return t1.price>t2.price;

}*/
bool operator <(t a, t b)
{
    return a.price > b.price;
}
int main()
{   int void1[10010]={0};
     int n1,i,j;int sum=0;
    cin>>n1;
   for(i=1;i<=n1;i++)
    cin>>t1[i].price>>t1[i].day;
sort(t1+1,t1+n1+1);

for(i=1;i<=n1;i++)
{
    if(void1[t1[i].day]==0)
        {sum+=t1[i].price;void1[t1[i].day]=1;}
    else {for(j=t1[i].day-1;j>=1;j--)
                                {if(void1[j]==0)
                                        {sum+=t1[i].price;
                                         void1[j]=1;
                                         break;
                                        }
                                }
          }

}
cout<<sum;

return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值