ZOJ - 4049 Halting Problem 题解【c++】

2 篇文章 0 订阅
1 篇文章 0 订阅

题目如下:

In computability theory, the halting problem is the problem of determining, from a description of an arbitrary computer program, whether the program will finish running (i.e., halt) or continue to run forever.

Alan Turing proved in 1936 that a general algorithm to solve the halting problem cannot exist, but DreamGrid, our beloved algorithm scientist, declares that he has just found a solution to the halting problem in a specific programming language -- the Dream Language!

Dream Language is a programming language consists of only 5 types of instructions. All these instructions will read from or write to a 8-bit register , whose value is initially set to 0. We now present the 5 types of instructions in the following table. Note that we denote the current instruction as the -th instruction.

InstructionDescription
add Add  to the register . As  is a 8-bit register, this instruction actually calculates  and stores the result into , i.e. . After that, go on to the -th instruction.
beq  If the value of  is equal to , jump to the -th instruction, otherwise go on to the -th instruction.
bne  If the value of  isn't equal to , jump to the -th instruction, otherwise go on to the -th instruction.
blt  If the value of  is strictly smaller than , jump to the -th instruction, otherwise go on to the -th instruction.
bgt  If the value of  is strictly larger than , jump to the -th instruction, otherwise go on to the -th instruction.

A Dream Language program consisting of  instructions will always start executing from the 1st instruction, and will only halt (that is to say, stop executing) when the program tries to go on to the -th instruction.

As DreamGrid's assistant, in order to help him win the Turing Award, you are asked to write a program to determine whether a given Dream Language program will eventually halt or not.

Input

There are multiple test cases. The first line of the input is an integer , indicating the number of test cases. For each test case:

The first line contains an integer  (), indicating the number of instructions in the following Dream Language program.

For the following  lines, the -th line first contains a string  (), indicating the type of the -th instruction of the program.

  • If  equals to "add", an integer  follows (), indicating the value added to the register;

  • Otherwise, two integers  and  follow (, ), indicating the condition value and the destination of the jump.

It's guaranteed that the sum of  of all test cases will not exceed .

Output

For each test case output one line. If the program will eventually halt, output "Yes" (without quotes); If the program will continue to run forever, output "No" (without quotes).

Sample Input

4
2
add 1
blt 5 1
3
add 252
add 1
bgt 252 2
2
add 2
bne 7 1
3
add 1
bne 252 1
beq 252 1

Sample Output

Yes
Yes
No
No

Hint

For the second sample test case, note that  is a 8-bit register, so after four "add 1" instructions the value of  will change from 252 to 0, and the program will halt.

For the third sample test case, it's easy to discover that the value of  will always be even, so it's impossible for the value of  to be equal to 7, and the program will run forever.

题记:

1.问题重述:“Halting Problem”是图灵停机问题,意思是执行表中的五种操作,若能停止则输出“Yes”,若程序会永远运行下去没有终止那一刻,则输出“No”。

2.问题分析:判断是否终止运行有两个条件:①共n步操作,需要进入n+1步操作,n+1步不存在,则停止运行。②每一步执行超过256次则视为改程序陷入了死循环,永远不会停止运行。

2.解题思路:①用instruction结构体存储输入的操作。②用step记录当前进行的操作是第几个,模拟程序运行过程。③用count[]数组记录每一步操作执行的次数,用于判断程序是否陷入了死循环。(详细步骤见代码中的注释)

C++代码如下:

#include <iostream>
#include <cstring>
using namespace std;

struct instruction{
	string operation;
	int v, k;
};

int main(int argc, char** argv) {
	int t;
	cin >> t;
	while(t--){
		int n;
		cin >> n;
		instruction s[n+2];
		
		//输入 
		for(int i=1; i<=n; i++){
			//读入操作 
			cin >> s[i].operation;
			//如果是add操作就读入v,否则读入v、k 
			if(s[i].operation[0] == 'a'){
				cin >> s[i].v;
			}else{
				cin >> s[i].v >> s[i].k;
			}
		}
		
		/*//调试
		for(int i=1; i<=n; i++){
			cout << "i:" << i << "  " << s[i].operation << "  " << s[i].v << "  " << s[i].k <<endl;
		} */
		
		//模拟
		int count[n+1] = {0}; //计数,256步之后还不停止则输出no
		int step = 1;    //记录当前操作步骤;
		int r = 0; 
		int flag = 0;    //记录是否结束 
		while(1){
		    count[step]++;
		    //如果当前操作是add……
			if(s[step].operation == "add"){
				r = (r + s[step].v) % 256;
				step++;
			}
			
			//如果当前操作是beq……
			else if(s[step].operation == "beq"){
				if(r == s[step].v){
					step = s[step].k;
				}else{
					step++;
				}
			}
			
			//如果当前操作是bne……
			else if(s[step].operation == "bne"){
				if(r != s[step].v){
					step = s[step].k;
				}else{
					step++;
				}
			}
			
			//如果当前操作是blt……
			else if(s[step].operation == "blt"){
				if(r < s[step].v){
					step = s[step].k;
				}else{
					step++;
				}
			}
			
			//如果当前操作是bgt……
			else if(s[step].operation == "bgt"){
				if(r > s[step].v){
					step = s[step].k;
				}else{
					step++;
				}
			}
			
			//判断结束
			if(step > n){
				flag = 1;
				break;
			} 
			if(count[step] >= 256){
				break;
			}
		} 
		
		//输出 
		if(flag){
			cout << "Yes" << endl;
		}else{
			cout << "No" << endl;
		}
    }
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值