POJ 2955 brackets

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
Sample Output

6
6
4
0
6
Source

Stanford Local 2004

题意:给定只包含‘(’ ‘)'[' ']'字符串 , 求正确匹配的最长长度。

思路:区间DP + 记忆化搜索  

区间DP:分治思想。 这里用记忆化搜索实现。

ans[I][J]  意为从i到j字符串的最长匹配长度 

转移方程  从start到finsh 中若能正确匹配ch[start] == ch[k] 

则ans[start][finsh] = max( ans[start][finsh] , dp(start+1,k-1) + dp(k+1,finsh) +2) ;

意为将start 到 finsh以k为中心分成两半 ,start+1 to k-1 和 k+1 to  finsh 。

 若不匹配 则 ans[start][finsh] = max( ans[start][finsh] , ans[start+1][finsh]) ;  

意为,从已经匹配的start+1 to finsh 的结果 与 当前保存的start to finsh 结果取较大值。

从这也可看出搜索时割分时入栈的顺序 : 1 :begin to end  2: begin+1 to end 。。start to end 。。end-1 to end 

ps  brackets : 方括号

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std ;
const int maxn = 100+10 ;
int brackets[maxn][maxn] ;
char ch[maxn] ;
bool judge(int start , int finsh) {
    if( ch[start]=='('&&ch[finsh]==')') return true ;
    if( ch[start]=='['&&ch[finsh]==']') return true ;
    return false ;
}
int dp(int beginn , int endd  ) {
    if( beginn > endd ) return 0 ;
    int& ans = brackets[beginn][endd] ;
    if(ans > 0 ) return ans ;
    dp(beginn+1,endd) ;
    for( int i = beginn+1 ; i <= endd ; ++i ) {
        if( judge(beginn,i)  ) {
            ans = max(ans, dp(beginn+1, i-1) + dp(i+1,endd)+2) ;
        }
        else
            ans = max(ans, brackets[beginn+1][endd]) ;
     }
    return  ans ;
}
int main( ) {
    while(~scanf("%s",ch)) {
        if(ch[0] == 'e') break;
        memset(brackets,0,sizeof(brackets)) ;
        dp(0,strlen(ch)-1) ;
        cout <<brackets[0][strlen(ch)-1]<< endl ;
    }
    return 0 ;
}









  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值