1093 Count PAT's (25 分) 我独特的思路(30分钟Ko)+别人的代码

1093 Count PAT's (25 分)  

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

我的思路是:

找到字符串中的A ,用两个数组,一个存放当前A左边的P的个数,另外一个存放当前A右边T的个数,

然后在扫描一遍字符串,如果当前字符是A,那就让P数组相应的元素乘上T数组相应的元素,累积这个乘积。

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
#define range 100005
#define mod 1000000007
string s;
int p[range]={0};
int t[range]={0};
int main()
{
	int i,j,len;
	int sum=0;
	cin>>s;
	len=s.length();
	for(i=0;i<len;i++)
	{
		if(s[i]=='P')
		{
			p[i+1]=p[i]+1;
		}
		else
		p[i+1]=p[i];
	}
	for(i=len-1;i>=0;i--)
	{
		if(s[i]=='T')
		t[i+1]=t[i+2]+1;
		else
		t[i+1]=t[i+2]; 
	}
	for(i=1;i<=len;i++)
	{
//		printf("%d  %d\n",p[i],t[i]);
		if(s[i-1]=='A')
		sum=(sum+p[i]*t[i])%mod;
	}
	printf("%d\n",sum);
	return 0;
}

还有省时间的,对p,t数组的操作可以放在一个for里。

刘姐的代码:

意思都一样,比我简洁

#include <iostream>
#include <string>
using namespace std;
int main() {
    string s;
    cin >> s;
    int len = s.length(), result = 0, countp = 0, countt = 0;
    for (int i = 0; i < len; i++) {
        if (s[i] == 'T')
            countt++;
    }
    for (int i = 0; i < len; i++) {
        if (s[i] == 'P') countp++;
        if (s[i] == 'T') countt--;
        if (s[i] == 'A') result = (result + (countp * countt) % 1000000007) % 1000000007;
    }
    cout << result;
    return 0;
}

 

 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值