1009 Product of Polynomials (25 分)

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

美滋滋美滋滋~~~~ 一直没想出来是啥错误,上课的时候突然想到 是因为当多个相乘为0时我用map其实还是存进去了

第一个测试点错误就是因为0的情况 而自己只考虑了一个等于0的情况 却没有考虑到多个等于0 的情况

多项式相乘的问题

代码:

import java.util.Scanner;
import java.util.TreeMap;
import java.util.Comparator;
import java.util.Map;
public class P1009 {
	static Scanner sc = new Scanner(System.in);
	static public class Pol{
		public int  index;
		public double ratio;
	}
	public static void main(String[] args) {
		int n, m;
		n = sc.nextInt();
		Pol a[] = new Pol[n]; //这边是定义指针  还需要再new对象
		for(int i = 0 ; i < n; i++)
		{
			Pol b = new Pol();
			b.index = sc.nextInt();
			b.ratio = sc.nextDouble();
			a[i] = b;
			b = null; 
		}
		m = sc.nextInt();
		Map<Integer, Double> map = new TreeMap<Integer, Double>(
                new Comparator<Integer>() {
                    public int compare(Integer obj1, Integer obj2) {
                        // 降序排序
                        return obj2.compareTo(obj1);
                    }
                });
		
		int index = 0 ;
		double ratio = 0;
		for(int i = 0 ; i < m; i++)
		{
			index = sc.nextInt();
			ratio = sc.nextDouble();
			for(int j = 0 ; j < n; j ++)
			{
				boolean contains = map.containsKey(index + a[j].index);
				if(contains)//可以相同的key值,但是添加的value值会覆盖前面的 
					map.put(index + a[j].index,ratio * a[j].ratio + map.get(index + a[j].index));
				else 
					map.put(index + a[j].index,ratio * a[j].ratio);
			}
		}
		int k = 0;
		for(Map.Entry<Integer, Double>entry1:map.entrySet()) {
			double gg = entry1.getValue();
			k = (int)gg;
			break;
		}  
		if(map.size() == 1 && k == 0)
		{
			System.out.printf("%d\n",0);
			System.exit(0);
		}
		
		System.out.printf("%d",map.size());
		for(Map.Entry<Integer, Double>entry:map.entrySet()) {
			System.out.printf(" %d %.1f",entry.getKey(),entry.getValue());
            	 
		}
	}
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值