1009 Product of Polynomials (25分)
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
#include<cstdio>
struct poly {
double c;
int e;
}a[1005],b[1005];
double exp[2005];
int main() {
int n1;
scanf("%d",&n1);
for(int i=0;i<n1;i++){
scanf("%d%lf",&a[i].e,&a[i].c);
}
int n2;
scanf("%d",&n2);
for(int i=0;i<n2;i++){
scanf("%d%lf",&b[i].e,&b[i].c);
}
poly temp;
for(int i=0;i<n1;i++){
for(int j=0;j<n2;j++){
temp.c=a[i].c*b[j].c;
temp.e=a[i].e+b[j].e;
exp[temp.e]+=temp.c;
}
}
int num=0;
for(int i=0;i<2005;i++){
if(exp[i]!=0){
num++;
}
}
printf("%d",num);
for(int i=2004;i>=0;i--){
if(exp[i]!=0){
printf(" %d %.1f",i,exp[i]);
}
}
return 0;
}
一次AC,此题和1002 A+B for Polynomials是相似的解法,比较简单