PAT A1014:Waiting in Line

题目描述

1014 Waiting in Line (30分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full,
all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number. Customeri will take Ti minutes to have his/her transaction processed.The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively.
At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2 . Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.
At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).The next line contains K positive integers, which are the processing time of the K customers.The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

求解思路

题意:给出窗口的数目n,窗口等待区最大容纳的人数m,顾客人数k,以及需要查询服务结束时间的顾客人数q。当窗口等待区没有满的时候,选择队伍最短的那个窗口进行排队,当窗口等待区已满的时候,选择队伍中第一个顾客服务结束时间最早的那个窗口进行排队。

  • 定义一个结构体Customer用于保存该顾客的服务时间长度以及顾客的服务结束时间
  • 定义一个结构体Window用于保存该窗口第一个顾客的服务结束时间以及最后一个顾客的服务结束时间,以及在该窗口中维护一个等待队列,即队列中的每个元素为该队列中顾客的服务时间长度
  • 处理分为两个部分:窗口等待区没有满的情况下,选择队伍最短的那个窗口进行排队,即按序来入队即可;当窗口等待区已满的情况下,选择队伍中第一个顾客服务结束时间最早的那个窗口进行排队。

代码(AC)

#include<stdio.h>
#include<queue>
#define MAXN 1005
using namespace std;
struct Customer{
	int during;	//顾客服务时间长度 
	int end;	//顾客服务结束时间 
}cus[MAXN]; 
struct Window{
	int poptime,endtime;	//队头元素出队时间,队尾元素处理结束时间
	queue<int>que;	//用于维护当前窗口的等待队列 
}win[25];
int n,m,k,q;	//窗口数目,等待线内的最大人数,顾客人数,查询人数 
int index=1;//用于标志已经到了第几个客户 
void init()
{
	scanf("%d %d %d %d",&n,&m,&k,&q);
	for(int i=1;i<=k;i++)
	{
		scanf("%d",&cus[i].during);
		cus[i].end=-1;
	}
}
void solve()
{
	/*等待区内,窗口没有满的情况下,客户按序选择队列短的入队*/
	for(int i=1;i<=m;i++)
	{
		for(int j=1;j<=n&&index<=k;j++,index++)	
		{	
			win[j].que.push(cus[index].during);	//按序加入队列 
			if(win[j].endtime<540)	cus[index].end=win[j].endtime+cus[index].during;	//没有更新之前进行判断 
			win[j].endtime+=cus[index].during;
			if(i==1)	win[j].poptime=win[j].endtime;//每个窗口的第一个人队首的出队时间等于其第一个人的服务结束时间	
		} 
	} 
	/*等待区外,窗口已满的情况下,客户选择队首出队时间更早的窗口排队*/
	while(index<=k)
	{
		int tempMin=win[1].poptime,tempWin=1;//当窗口已满的时候
		for(int i=2;i<=n;i++)
		{
			if(win[i].poptime<tempMin)
			{
				tempMin=win[i].poptime;
				tempWin=i;
			}
		}	
		win[tempWin].que.pop();	//队首元素出队
		win[tempWin].que.push(cus[index].during);
		win[tempWin].poptime+=win[tempWin].que.front();//更新队首元素的出队时间
		if(win[tempWin].endtime<540)	cus[index].end=win[tempWin].endtime+cus[index].during; 	//没有更新之前进行判断 
		win[tempWin].endtime+=cus[index].during;	//更新队尾元素的服务结束时间
		index++; 
	} 
} 
void print()
{
	int id;
	for(int i=1;i<=q;i++)
	{
		scanf("%d",&id);
		if(cus[id].end==-1)	printf("Sorry\n");
		else printf("%02d:%02d\n",8+cus[id].end/60,cus[id].end%60);	
	}	
} 
int main()
{
	init();
	solve();
	print();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值