1014 Waiting in Line (30分) 队列,银行排队

1014 Waiting in Line (30分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer
​i
​​will take T
​i
​​minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​is served at window​1​​while customer​2​​is served at window2​​. Customer​3​​will wait in front of window​1​​and customer​4​​will wait in front of window​2​​. Customer​5​​will wait behind the yellow line.At 08:01, customer​1​is done and customer​5​​enters the line in front of window​1​​since that line seems shorter now. Customer​2​​will leave at 08:02, customer​4​at 08:06, customer​3​​at 08:07, and finally customer​5​​at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

心得

感觉每次做PAT的时候,代码倒不是难点,主要是代码的描述不清楚,很多事情都需要自己猜,然后测试点却进行了测试,单单17.00之前来就可以服务。银行实际上也不全都是这样,但题目是这样出的,并且说的也不太明确。对题目还是要多多理解,多读几次题目,要不想错了,再写代码,就很麻烦了。

通过这个题,也学到了一个测试方法,输入条件的最大值和最小值分别测试,就可以测试自己程序的边界。程序的边界一直是容易出问题的地方。

错误

if ((iN + j) >= K) 这个iN 一直写成了iM 真的没想到是这个错误,找了好几个小时,
内层嵌套循环,肯定是对i
内侧的数量啊!!!!

#include<iostream>
#include <vector>
#include <queue>
using namespace std;

typedef struct {
	int endtime;
	queue<int>peopletime;
}Windows;
Windows windows[20];

int people[1000];
int N, M, K, Q;
int searmin() {
	int min=99999;
	for (int i = 0; i < N; i++)
	{
		if (windows[i].peopletime.front() < min) min = windows[i].peopletime.front();
	}
	for (int i = 0; i < N; i++)
	{
		if (windows[i].peopletime.front() == min) {
			return i;
		}
	}
}
int main() {
	cin >> N >> M >> K >> Q;//N窗口数量,M每个队伍最多的人数 K顾客数量 Q查询数量
	if (N == 0 || M == 0) {
		for (int i = 0; i < K+Q; i++)
		{
			int o;
			cin >> o;
		}
		for (int i = 0; i < Q; i++)
		{
			cout << "Sorry" << "\n";
		}
		return 0;
	}
	for (int i = 0; i < K; i++)
	{
		people[i] = 99999;
	}
	for (int i = 0; i < M; i++)
	{
		for (int j = 0; j < N; j++)
		{
			if ((i*N + j) >= K) continue;
			int time;
			cin >> time;
			
			if (windows[j].endtime >= 540) {
				people[i*N + j] = 99999;
				windows[j].peopletime.push(people[i*N + j]);
			}
			else {
				windows[j].endtime += time;
				people[i*N + j] = windows[j].endtime;
				windows[j].peopletime.push(people[i*N + j]);
			}
			
		}
	}
	for (int i = N*M; i < K; i++)
	{
		int time;
		cin >> time;
		int min = searmin();
		
		if (windows[min].endtime >= 540) {
			people[i] = 99999;

		}
		else {
			windows[min].endtime += time;
			people[i] = windows[min].endtime;
			windows[min].peopletime.pop();
			windows[min].peopletime.push(people[i]);
		}
	}
	for (int i = 0; i < Q; i++)
	{
		int number;
		cin >> number;
		int now = people[number - 1];
		if (now == 99999)cout << "Sorry" << "\n";
		else {
			int hour = now / 60+8;
			int minute = now % 60;
			if (hour < 10)cout << "0";		
			cout << hour << ":";
			if (minute < 10)cout << "0";
			cout << minute << "\n";
		}
		
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值