1110 Complete Binary Tree (25 分)(搜索)

1110 Complete Binary Tree (25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

嘤嘤嘤  被自己蠢哭了

代码:

#include<bits/stdc++.h>	
using namespace std;
struct Node{
	int data;
	int l,r;
}gg[25];
int flag = 0, maxn = -1,ans;
void DFS(int root, int id)
{
	if(id > maxn){
		maxn = id;
		ans = root;
	}
	if(gg[root].l != -1)
		DFS(gg[root].l, id * 2);
	if(gg[root].r != -1)
		DFS(gg[root].r, id * 2 + 1);
	return ;
}
int main()
{
	int n;
	char s1[5],s2[5];
	int b[22] = {0};
	scanf("%d", &n);
	for(int i = 0 ;i < n; i++)
	{
		scanf("%s %s",s1,s2);
		if(s1[0] == '-')
			gg[i].l = -1;
		else 
		{
			int data = 0, now = 0;
			while(s1[now] != '\0')
				data = data * 10 + s1[now++]-'0'; 
			b[data] = 1;
			gg[i].l = data;
		}
		if(s2[0] == '-')
			gg[i].r = -1;
		else 
		{
			int data = 0, now = 0;
			while(s2[now] != '\0')
				data = data * 10 + s2[now++]-'0'; 
			b[data] = 1;
			gg[i].r = data;
		}
		gg[i].data = i;
	}
	int root = 0;
	for(int i = 0; i < n; i ++)
	{
		if(b[i] == 0)
		{
			root = i;
			break;
		}	
	}
	DFS(root, 1);
	if(maxn == n)
		printf("YES %d\n",ans);
	else 
		printf("NO %d\n",root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值