1110 Complete Binary Tree (25 分)(完全二叉树,注意读题,哭了)

1110 Complete Binary Tree (25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
struct node{
	int l,r;
}p[100];
bool mp[100];
int get_num(char s[]){
	int num=0;
	int len=strlen(s);
	for(int i=0;i<len;i++) num=num*10+(s[i]-'0');
	return num;
}
void get_son(int fa,char ls[],char rs[]){
	if(ls[0]=='-') p[fa].l=-1;
	else{
		int lson=get_num(ls);
		p[fa].l=lson;
		mp[lson]=true;
	}
	if(rs[0]=='-') p[fa].r=-1;
	else{
		int rson=get_num(rs);
		p[fa].r=rson;
		mp[rson]=true;
	}
}
int mx=-1,ans;
void dfs(int fa,int index){
	if(index>mx) mx=index,ans=fa;
	if(p[fa].l!=-1) dfs(p[fa].l,index<<1);
	if(p[fa].r!=-1) dfs(p[fa].r,index<<1|1);
}
int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
    	char ls[5],rs[5];
    	scanf("%s%s",ls,rs);
    	get_son(i,ls,rs);	
	}
    int root=-1;
    for(int i=0;i<n;i++){
    	if(!mp[i]){
    		root=i;
    		break;
		}
	} 
	dfs(root,1);
	if(mx==n) printf("YES %d\n",ans);
	else printf("NO %d\n",root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值