1110 Complete Binary Tree(25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

思路:

给出一个n表示有n个结点,这n个结点为0~n-1,给出这n个结点的左右孩子,求问这棵树是不是完全二叉树

C++:

#include "cstdio"
#include "iostream"
#include "queue"
#include "string"
using namespace std;
struct node
{
	int lchild,rchild;
};
node tree[25];
int book[25]={0};
int main(){
	int n;
	string temp1,temp2;
	scanf("%d",&n);
	for (int i=0;i<n;i++)
	{
		cin>>temp1>>temp2;
		getchar();
		if (temp1=="-")
		{
			tree[i].lchild=-1;
		}else
		{
			tree[i].lchild=stoi(temp1);
			book[stoi(temp1)]=1;
		}
		if (temp2=="-")
		{
			tree[i].rchild=-1;
		}else
		{
			tree[i].rchild=stoi(temp2);
			book[stoi(temp2)]=1;
		}
	}
	//记录根结点
	int root=-1;
	for (int i=0;i<n;i++)
	{
		if(book[i]==0){root=i;break;}
	}
	queue<int> q;
	q.push(root);
	int cnt = 0, lastnode = 0;
	while(!q.empty()) {
		int temp = q.front();
		q.pop();
		if(temp != -1) {
			lastnode = temp;
			cnt++;
		}else {
			if(cnt != n)
				printf("NO %d", root);
			else
				printf("YES %d", lastnode);
			return 0;
		}
		q.push(tree[temp].lchild);
		q.push(tree[temp].rchild);
	}
	return 0;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是用C语言实现判断二叉树是否为完全二叉树的代码: ```c #include <stdio.h> #include <stdlib.h> // 定义二叉树结点 struct Node { int val; struct Node *left, *right; }; // 计算二叉树的结点数量 int countNodes(struct Node* root) { if (root == NULL) { return 0; } return 1 + countNodes(root->left) + countNodes(root->right); } // 判断二叉树是否为完全二叉树 int isCompleteTree(struct Node* root, int index, int numNodes) { // 如果为空树,返回true if (root == NULL) { return 1; } // 如果当前结点的索引超过了结点数量,返回false if (index >= numNodes) { return 0; } // 递归判断左右子树是否为完全二叉树 return isCompleteTree(root->left, 2 * index + 1, numNodes) && isCompleteTree(root->right, 2 * index + 2, numNodes); } int main() { // 创建一个二叉树 struct Node* root = (struct Node*)malloc(sizeof(struct Node)); root->val = 1; root->left = (struct Node*)malloc(sizeof(struct Node)); root->left->val = 2; root->left->left = (struct Node*)malloc(sizeof(struct Node)); root->left->left->val = 4; root->left->right = (struct Node*)malloc(sizeof(struct Node)); root->left->right->val = 5; root->right = (struct Node*)malloc(sizeof(struct Node)); root->right->val = 3; root->right->left = (struct Node*)malloc(sizeof(struct Node)); root->right->left->val = 6; int nodeCount = countNodes(root); int index = 0; if (isCompleteTree(root, index, nodeCount)) { printf("This is a complete binary tree.\n"); } else { printf("This is not a complete binary tree.\n"); } return 0; } ``` 该程序首先定义了一个二叉树结点的结构体,包含结点值、左右子树的指针。接着定义了两个函数: - `countNodes`:计算二叉树的结点数量,使用递归方式遍历二叉树,每遍历一个结点,就累加1,最终返回结点数量。 - `isCompleteTree`:判断二叉树是否为完全二叉树,使用递归方式遍历二叉树,同时记录每个结点的索引。如果当前结点的索引超过了结点数量,说明已经遍历到了不存在的结点,因此返回false。如果当前结点的索引小于结点数量,就继续递归遍历它的左右子树,直到遍历完整棵树。如果递归过程中没有返回false,说明该树是完全二叉树,返回true。 在主函数中,我们创建了一个二叉树,并调用`countNodes`计算结点数量,调用`isCompleteTree`判断二叉树是否为完全二叉树。最终根据返回值输出判断结果。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值