1110 Complete Binary Tree(25 分)(cj)

1110 Complete Binary Tree(25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

果然 ! 数组是做完美或完全二叉树的神器!! 

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
using namespace std;
int tree[22][2];
int treearr[22];
bool vis[22];
void init();
int tran(string s);
bool iscomplete(int idex, int pos);
int n;
int main() {
	init();
	cin >> n;
	string a, b;
	for (int i = 0; i < n; ++i) {
		cin >> a >> b;
		if (a != "-") {
			tree[i][0] = tran(a);
			vis[tree[i][0]] = 1;
		}
		if (b != "-") {
			tree[i][1] = tran(b);
			vis[tree[i][1]] = 1;
		}
	}
	int root;
	for (int i = 0; i < n; ++i) {
		if (vis[i] == 0) {
			root = i;
			break;
		}
	}
	if (iscomplete(root,1)) {
		cout << "YES" << ' ' << treearr[n] << endl;
	}
	else {
		cout << "NO" << ' ' << root << endl;
	}
	system("pause");
	return 0;
}
void init() {
	for (int i = 0; i < 22; ++i) {
		tree[i][0] = -1;
		tree[i][1] = -1;
	}
}
int tran(string s) {
	int res = 0;
	for (int i = 0; i < s.size(); ++i) {
		res *= 10;
		res += (s[i] - '0');
	}
	return res;
}
bool iscomplete(int idex, int pos) {
	if (idex == -1) return 1;
	if (pos > n) return 0;
	if (iscomplete(tree[idex][0], pos * 2) == 0) return 0;
	if (iscomplete(tree[idex][1], pos * 2 + 1) == 0) return 0;
	treearr[pos] = idex;
	return 1;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值