The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (≤230).
Output Specification:
For each test case, print the number of 1's in one line.
Sample Input:
12
Sample Output:
5
题目大意:给一个N,求从1~N过程中 1出现的次数。
分析:根据当前位(now)分三类讨论
1) now==0 ans+=*a;
2) now==1 ans+=left*a+right+1;
3) now>=2 ans+=(left+1)*a;
now表示当前位上的数字,left表示当前位左侧数字,right表示当前位的右侧数字,a表示当前是第几位(个、十、百...)
(来自算法笔记)
AC代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
int n,a=1,ans=0;
int left,now,right;
cin>>n;
while(n/a!=0){
left=n/(a*10); //当前位的左边
now=n/a%10; //当前位的数字
right=n%a; //当前位的右边
if(now==0) ans+=left*a;
else if(now==1) ans+=left*a+right+1;
else ans+=(left+1)*a;
a*=10;
}
printf("%d\n",ans);
return 0;
}
考场上这题肯定推不出来,只能暴力混个分了。