1049 Counting Ones (30 分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2​30​​).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

题目大意:给一个N,求从1~N过程中 1出现的次数。

分析:根据当前位(now)分三类讨论
1) now==0   ans+=*a;

2)   now==1    ans+=left*a+right+1;

3)   now>=2    ans+=(left+1)*a;

now表示当前位上的数字,left表示当前位左侧数字,right表示当前位的右侧数字,a表示当前是第几位(个、十、百...)

(来自算法笔记)

AC代码:

#include<bits/stdc++.h> 
using namespace std;
int main(){
	int n,a=1,ans=0;
	int left,now,right;
	cin>>n;
	while(n/a!=0){
		left=n/(a*10); //当前位的左边 
		now=n/a%10;    //当前位的数字 
		right=n%a;     //当前位的右边 
		if(now==0) ans+=left*a; 
		else if(now==1) ans+=left*a+right+1;
		else ans+=(left+1)*a;
		a*=10;
	}
	printf("%d\n",ans);
	return 0;
}

考场上这题肯定推不出来,只能暴力混个分了。
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值