poj2955(区间DP)

地址:http://poj.org/problem?id=2955

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2601 Accepted: 1344

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n,ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意:求最大匹配的括号数。

思路:区间DP,状态专题方程:

                  if((bk[i]=='('&&bk[k]==')')||(bk[i]=='['&&bk[k]==']'))
                        dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
                    else dp[i][j]=max(dp[i][j],dp[i][k-1]+dp[k][j]);

代码:

#include<iostream>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define LL __int64
#define Mod 0xfffffff
char bk[110];
int dp[110][110];
int main(){
    while(scanf("%s",bk)>0){
        if(bk[0]=='e') break;
        int len=strlen(bk);
        memset(dp,0,sizeof(dp));
        for(int l=1;l<len;l++){
            for(int i=0;i<len-l;i++){
                int j=i+l;
                for(int k=i+1;k<=j;k++){
                    if((bk[i]=='('&&bk[k]==')')||(bk[i]=='['&&bk[k]==']'))
                        dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
                    else dp[i][j]=max(dp[i][j],dp[i][k-1]+dp[k][j]);
                }
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
    return 0;
}

/*测试数据:
[(((])))   6
[((([])))   8
*/




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值