zoj3469(区间DP)

地址:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4255

Food Delivery

Time Limit: 2 Seconds       Memory Limit: 65536 KB

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55


题意:送餐,有N个顾客坐在一个x轴上,第i个人的位置是Xi,他的不满意成长度为Bi没分钟。你的起始位置为X,送餐速度为1/V每分钟,问给所有人送餐完后最小的不满意度为多少?

思路:许久没A题了,手有点生,专门挑了道以前想过一些的题来做,结果还是看了别人的结题报告才写出来。引文要从起始位置开始送餐,而且以前做过的区间DP没有要考虑这个,所以卡住了。看了下http://www.cnblogs.com/kuangbin/archive/2013/04/30/3051919.html,他的做法就是讲送餐过程模拟出来。做这题时我应该是想多了,因为经过的顾客一定会给其送上餐,而且你跳过这份顾客不向其送餐又不会减少时间,所以需要考虑的只有是先给右边的人送,还是先给左边的人送,只要这里模拟出来,就没问题了。总结下,有事后做题不能太纠结于模板,例如这题,属于区间DP,但其写法可以说不同于以前的那些。

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define LL __int64
#define Ma 0xfffffff
struct node
{
    int x,b;
} pp[1010];
int dp[1010][1010][2],sum[1010];
bool kmp(node a,node b)
{
    return a.x<b.x;
}
int main()
{
    int n,v,st,ed;
    while(scanf("%d%d%d",&n,&v,&st)>0)
    {
        for(int i=0; i<n; i++)
            scanf("%d%d",&pp[i].x,&pp[i].b);
        pp[n].x=st;
        pp[n++].b=0;
        sum[0]= 0;
        sort(pp,pp+n,kmp);
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
                dp[i][j][0]=dp[i][j][1]=Ma;
            if(pp[i].x==st) ed=i;
            sum[i+1]=sum[i]+pp[i].b;
        }
        dp[ed][ed][0]=dp[ed][ed][1]=0;
        for(int i=ed; i>=0; i--)
        {
            for(int j=ed; j<n; j++)
            {
                if(i==j) continue;
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(sum[i+1]+sum[n]-sum[j+1])*(pp[i+1].x-pp[i].x));
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(sum[i+1]+sum[n]-sum[j+1])*(pp[j].x-pp[i].x));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(sum[i]+sum[n]-sum[j])*(pp[j].x-pp[i].x));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(sum[i]+sum[n]-sum[j])*(pp[j].x-pp[j-1].x));
            }
        }
        printf("%d\n",min(dp[0][n-1][0],dp[0][n-1][1])*v);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值