ZOJ 3706 模拟 水题 STL

题目:

Break Standard Weight

Time Limit: 2000 msMemory Limit: 65536 KB
The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term “scales” for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input
There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ x, y ≤ 100

Output
For each test case, output the maximum number of possible special masses.

Sample Input
2
4 9
10 10
Sample Output
13
9
理解题意即可,水题
两个砝码,每次必须分一个砝码得到两个砝码,然后用三个砝码去测一个物体的重量。求最多的取值
保证物体重量大于0
用set去重即可

#include<bits/stdc++.h>
const double PI=acos(-1.0);
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&-x
#define inf 0x3f3f3f3f
#define pr pair<int,int>
typedef pair<char,int> PAIR;
struct CmpByValue
{
    bool operator()(const PAIR& lhs, const PAIR& rhs)
    {
        return lhs.second > rhs.second;
    }
};
//priority_qe<int,vector<int>,greater<int>> pp;
/*
理解题意即可,水题
	两个砝码,每次必须分一个砝码得到两个砝码,然后用三个砝码去测一个物体的重量。求最多的取值
	保证物体重量大于0
*/
const int mod = 123456789 ;
const int M = 15000 +10 ;
const int limt = 1<<20;
const int INF = 1e9;
typedef long long ll;
set<int>pp;//去重
void ok(int a,int b,int c)
{
    //1
    pp.insert(a);
    pp.insert(b);
    pp.insert(c);
    //2
    if(a+b>0)
        pp.insert(a+b);
    if(a-b>0)
        pp.insert(a-b);
    if(a+c>0)
        pp.insert(a+c);
    if(b-a>0)
        pp.insert(b-a);
    if(b-c>0)
        pp.insert(b-c);
    if(c+b>0)
        pp.insert(c+b);
    if(c-b>0)
        pp.insert(c-b);
    if(c-a>0)
        pp.insert(c-a);
    if(a-c>0)
        pp.insert(a-c);
    //3
    if(a+b+c>0)
        pp.insert(a+b+c);
    if(b-a+c>0)
        pp.insert(b-a+c);
    if(c-b-a>0)
        pp.insert(c-b-a);
    if(a+c-b>0)
        pp.insert(a+c-b);
    if(a+b-c>0)
        pp.insert(a+b-c);
    if(a-b-c>0)
        pp.insert(a-b-c);
    if(b-a-c>0)
        pp.insert(b-a-c);
}
int main()
{
    ios::sync_with_stdio(0);//加快cin,cout,和scanf差不多的速度
    int t,n,m;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        int j,i;
        ll man=0;
        for( i=1; i<=n/2; i++)//分割n
        {
            pp.clear();
            j=n-i;  //另一份
            ok(i,j,m);//操作
            if(pp.size()>man)//取最大值
                man=pp.size();
        }

        for( i=1; i<=m/2; i++)//分割m
        {
            pp.clear();
            j=m-i; //另一份
            ok(i,j,n);//操作

            if(pp.size()>man)//取最大值
                man=pp.size();
        }
        cout<<man<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值