1585—Score

There is anobjective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem andan `X' means a wronganswer. The score of each problem of this test is calculated by itself and itsjust previous consecutive `O's only when the answer is correct. Forexample, the score of the 10th problem is 3 that is obtained by itself and itstwo previous consecutive `O's.

Therefore, thescore of ``OOXXOXXOOO" is 10 which is calculated by``1+2+0+0+1+0+0+1+2+3".

You are to write aprogram calculating the scores of test results.

Input 

Your program is toread from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input.Each test case starts with a line containing a string composed by `O' and `X' and the lengthof the string is more than 0 and less than 80. There is no spaces between `O' and `X'.

Output 

Your program is towrite to standard output. Print exactly one line for each test case. The lineis to contain the score of the test case.

The followingshows sample input and output for five test cases.

Sample Input 

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output 

10

9

7

55

30

代码:

#include<iostream>

using namespace std;

int main()

{

   int test;

   cin>>test;

   while(test--)

    {

       string s;

       cin>>s;

       int num=0,sum=0;

       for(int i=0;i<s.size();i++)

       {

           if(s[i]!='X')

           {

                num++;

                sum=sum+num;

           }

           else

           {

                num=0;

           }

       }

       cout<<sum<<endl;

    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值