PAT-A1023 Have Fun with Numbers 【散列】

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

Tips:

  • 题目说数字长度在20位一下,int(10),double(16)都不行,只能选择使用string来保存了,按照字符一位一位去乘。
  • 想这样一个问题,如果开头的数字大于等于5,那么结果位数一定多一位,一定输出No,多出来的1位是‘1’,直接按照最高位小于等于4的方法一样乘就行了。
  • map散列。char为主键,出现次数为值。
#include <iostream>
#include <string>
#include <map>
using namespace std;
map<char,int> data;
map<char,int> res;
void times(string s){
	bool go=false;        //最高位是否>=5
	if((s[0]-'0')>=5){
		printf("No\n");
		go=true;
	} 
	int flag=0;           //进位标志
	for(int i=s.size()-1;i>=0;i--){
		int temp=(s[i]-'0');
		temp*=2;
		temp+=flag;
		if(temp>=10){
			temp-=10;
			flag=1;       //进位置1
		}
		else{
			flag=0;       //进位置0
		}
		s[i]=temp+'0';
		res[s[i]]+=1;
	}
	if(go){
		printf("1%s",s.c_str());
		return;
	}
	for(int j=0;j<s.size();j++){
		if(data[s[j]]==res[s[j]]) continue;
		else{
			printf("No\n");
			printf("%s",s.c_str());
			return;
		}
	}
	printf("Yes\n");
	printf("%s",s.c_str());

	
}
int main(){
	string num;
	cin>>num;
	for(int i=0;i<num.size();i++){
		data[num[i]]+=1;
	}
	times(num);
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值