PAT-A-1090 Highest Price in Supply Chain【树】

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

老规矩,使用Vector存储树。但是这道题有点小别扭,以前树的存储都是给parentId,然后是子节点,但是这道题稍微有点变化,输入数据的下标是孩子Id,值是parentId。所以还有一个问题,就是根节点的id是-1,vector的下标平时从0开始的,因此我使用了一个额外的vector保存根节点。

然后求这棵树的深度和最后一层的子节点数。跟1094有点像,都可以借助vector来计算层数和深度,但是如果只要求计算深度的话,我觉得还是DFS更好用一点。

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
vector<int> nodes[100002];   //保存子树
int main(){
	vector<int> root;        //保存根节点I
	int N,temp;
	double initprice,speed;
	scanf("%d %lf %lf",&N,&initprice,&speed);
	for(int i=0;i<N;i++){
		scanf("%d",&temp);
		if(temp==-1){
			root.push_back(i);      //如果是-1,则保存到根节点数组
		}else{
			nodes[temp].push_back(i);
		}
	}
	vector<int> data;
	int level=0,max=0;
	for(int k=0;k<root.size();k++){    //把根节点的孩子放到data中
		data.push_back(root[k]);
	}
	while(!data.empty()){
		int size=data.size();          //获取当代size
		max=size;
		for(int j=0;j<size;j++){
			for(int l=0;l<nodes[data[j]].size();l++){  //添加当代的孩子节点
				data.push_back(nodes[data[j]][l]);
			}	
		}
		data.erase(data.begin(),data.begin()+size);   //删除当代
		if(level) initprice*=(1+0.01*speed);
		level++;
	}
	printf("%.2lf %d",initprice,max);
	return 0;
}

 

 

 

 

PS:我晕。。。。。。。。。。。。。。。。。。。。。

        第一次提交只过了两个用例,剩下的都是段错误,只能是vector引发的错误。我看了半天程序的逻辑,觉得没定点错误啊。

遂自暴自弃,不做了,玩了一个晚上。结果今天早上再一拿起来看,题目要求总节点10的五次幂,我开了10002虽然是五位,但是这是10的四次幂啊,我晕。下次注意啊 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值