PAT A1049题解


1049 Counting Ones (30 分)
The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:
Each input file contains one test case which gives the positive N (≤2
​30
​​ ).

Output Specification:
For each test case, print the number of 1’s in one line.

Sample Input:
12
Sample Output:
5


题目大意:给定一个数,列举1-n,统计其中的1的个数


题目思路:一开始没有注意到时间限制,所以当然第一反应是进行n^2复杂度的两重循环列举,但是明显这样是不符合题意,定然超时的。所以一开始写的是这样的。


//部分超时代码
#include<cstdio>
#include<iostream>
using namespace std;
int change(int n,int a[]){
	int count=0;
	while(n!=0){
		a[count++]=n%10;
		n=n/10;
	}
}
int main(){
	int n,m,sum=0;
	cin>>n;
	for(int i=1;i<=n;i++){
		int a[10]={0};
		change(i,a);
		for(int j=0;j<10;j++){
			if(a[j]==1){
				sum++;
			}
		}
	}
	cout<<sum;
	return 0;
}

在考虑到时间限制当中,还是得要找到数学上的规律才能符合题意。


//AC 代码
#include <iostream>
using namespace std;
int main() {
    int n, left = 0, right = 0, a = 1, now = 1, ans = 0;
    scanf("%d", &n);
    while(n / a) {
        left = n / (a * 10), now = n / a % 10, right = n % a;
        if(now == 0) ans += left * a;
        else if(now == 1) ans += left * a + right + 1;
        else ans += (left + 1) * a;
        a = a * 10;
    }
    printf("%d", ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值