E - 4 Values whose Sum is 0

Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output
For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

4组数据求和,先两两划分,分别求两组数的和,再对其中一组和数组查重并记录,再枚举另一个和数组的数据,二分搜索查找已经查重数组的数据即可。
代码如下:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<stdio.h>
#include<map>
#define MAXN 4000+10
typedef long long LL;
using namespace std;

LL a[MAXN];
LL b[MAXN];
LL c[MAXN];
LL d[MAXN];
LL ab[MAXN * MAXN];
LL cd[MAXN * MAXN];
map<LL,LL> ma;

int bs(LL key, int n)
{
    int lo = 0, hi = n*n - 1;
    int mi;
    while(lo <= hi)
    {
        mi = ((hi-lo)>>1) + lo;
        //cout << mi << endl;
        //cout << key + cd[mi] << endl;
        while(key + cd[mi] == 0)
            return mi;
        if(key + cd[mi] < 0)
            lo = mi + 1;
        else
            hi = mi - 1;
        //cout << lo << " " << hi << endl;
    }
    return -1;
}

int main()
{
    int n;
    int sum;
    //freopen("in.txt","r",stdin);

    while(cin >> n)
    {
        sum = 0;
        for(int i = 0; i < n; i++)
            cin >> a[i] >> b[i] >> c[i] >> d[i];
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
                ab[i*n+j] = a[i] + b[j];
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
                cd[i*n+j] = c[i] + d[j];
        sort(cd,cd+n*n);
        LL temp = cd[0];
        ma.insert(make_pair(cd[0],1));
        for(int i = 1; i < n*n; i++)
        {
            if(cd[i] == temp)
                ma[cd[i]]++;
            else
            {
                temp = cd[i];
                ma[temp]++;
            }
        }
        for(int i = 0; i < n*n; i++)
        {
            //cout << ab[i] << endl;
            int mi = bs(ab[i], n);
            //cout << ab[i] << " " << cd[0] << endl;
            if(mi != -1)
            {
                //cout << ab[i] << endl;
                sum += ma[cd[mi]];
               // cout << ma[cd[mi]] << endl;
                //cout << ma[cd[mi]] << endl;
            }
        }
        cout << sum << endl;
        ma.clear();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值