Minimum Inversion Number(线段树)

Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 
 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 
 

Output

For each case, output the minimum inversion number on a single line. 
 

Sample Input

    
    
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output

    
    
16

解题思路

之前做了两题都是完全套的模板,这题用来求逆序对一下转不过来了,于是看看骆大神的代码,原来如此!

题中已经有对逆序对的简单介绍,但还是在此贴下逆序数的概念:

在一个排列中,如果一对数的前后位置与大小顺序相反,即前面的数大于后面的数,那么它们就称为一个逆序。一个排列中逆序的总数就称为这个排列的逆序数。

逆序数为偶数的排列称为偶排列;逆序数为奇数的排列称为奇排列; 如2431中,21,43,41,31是逆序,逆序数是4,为偶排列。

也是就说,对于n个不同的元素,先规定各元素之间有一个标准次序(例如n个 不同的自然数,可规定从小到大为标准次序),

于是在这n个元素的任一排列中,当某两个元素的先后次序与标准次序不同时,就说有1个逆序。一个排列中所有逆序总数叫做这个排列的逆序数。

*那么如何用线段树做呢,build时都初始化为0,每次输入后先query,找出前面已经输入的数中比自己大的数,怎么找的呢,每次会对输入的数update,值为1;



AC代码

#include <iostream>
#include <cstdio>
using namespace std;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
const int maxn = 5005;
int sum[maxn << 2];
void PushUp(int rt)
{
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void build(int l, int r, int rt = 1)
{
    sum[rt] = 0;
    if(l == r)
        return;
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}
void update(int p, int l, int r, int rt = 1)
{
    if(l == r)
    {
        sum[rt]++;
        return;
    }
    int m = (l + r) >> 1;
    if(p <= m)
        update(p, lson);
    else
        update(p, rson);
    PushUp(rt);
}
int query(int L, int R, int l, int r, int rt = 1)
{
    if(L <= l && r <= R)
        return sum[rt];
    int m  = (l + r) >> 1;
    int ret = 0;
    if(L <= m)
        ret += query(L, R, lson);
    if(m < R)
        ret += query(L, R, rson);
    return ret;
}
int main()
{
    int n, a[maxn], sum, ans;
    while(scanf("%d", &n) != EOF)
    {
        sum = 0;
        build(1, n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            sum += query(a[i] + 1, n, 1, n);
            update(a[i], 1, n);
        }
        ans = sum;
        for(int i = 1; i <= n; i++)
        {
            sum += n - 1 - 2 * a[i];
            ans = min(ans, sum);
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值