Kiki & Little Kiki 1

Kiki & Little Kiki 1
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 711 Accepted Submission(s): 237

Problem Description
Kiki is considered as a smart girl in HDU, many boys fall in love with her! Now, kiki will finish her education, and leave school, what a pity! One day, zjt meets a girl, who is like kiki very much, in the campus, and calls her little kiki. Now, little kiki want to design a container, which has two kinds of operation, push operation, and pop operation.
Push M:
Push the integer M into the container.
Pop M:
Find the maximal integer, which is not bigger than M, in the container. And pop it from the container. Specially, for all pop operations, M[i] is no bigger than M[i+1].
Although she is as smart as kiki, she still can't solve this problem! zjt is so busy, he let you to help little kiki to solve the problem. Can you solve the problem?


Input
The input contains one or more data sets. At first line of each input data set is an integer N (1<= N <= 100000) indicate the number of operations. Then N lines follows, each line contains a word (“Push” or “Pop”) and an integer M. The word “Push” means a push operation, while “Pop” means a pop operation. You may assume all the numbers in the input file will be in the range of 32-bit integer.


Output
For each pop operation, you should print the integer satisfy the condition. If there is no integer to pop, please print “No Element!”. Please print a blank line after each data set.


Sample Input

9 Push 10 Push 20 Pop 2 Pop 10 Push 5 Push 2 Pop 10 Pop 11 Pop 19 3 Push 2 Push 5 Pop 2


Sample Output

No Element! 10 5 2 No Element! 2

#include<set>  
#include<cstdio>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

int n;  
multiset<int> st;  

void solve(int x){  
	if (st.empty()||x<*(st.begin()))
	{
		cout<<"No Element!"<<endl;
		return;
	}
	multiset<int>::iterator it;
	it=st.find(x);
	if (it!=st.end())
	{
		cout<<*it<<endl;
		st.erase(it);
	}
	else
	{
		multiset<int>::iterator it2;
		st.insert(x);
		it=it2=st.find(x);
		cout<<*(it2--)<<endl;
		st.erase(it);
		st.erase(it2);
	}
}  

int main(){  
	char str[10];  
	int x;  
	while(scanf("%d",&n)!=EOF)
	{
		st.clear();
		while(n--)
		{
			scanf("%s %d",str,&x);
			if(strcmp(str,"Push"))
				st.insert(x);
			else
				solve(x);
		}
		puts("");
	}
	return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值