hdu 1496 -- Equations


Problem Description
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
  
  
1 2 3 -4 1 1 1 1
 

Sample Output
  
  
39088 0
 


#include <iostream>
using namespace std;
int base[101];

int hash[2000009];

int main()
{
	int a,b,c,d;
	int i,j,k;
	for(i=0;i<101;i++)
		base[i]=i*i;

	while(scanf("%d %d %d %d",&a,&b,&c,&d)!=EOF)
	{
		
		if( (a>0 && b>0 && c>0 && d>0 )|| (a<0 && b<0 && c<0 && d<0) )
		{      printf("0/n");
			   continue;      
		}
		else
		{
			memset(hash,0,sizeof(hash));
			for(i=1;i<101;i++)
				for(j=1;j<101;j++)
					hash[base[i]*a+base[j]*b+1000000]++;

			int sum=0;
			
			for(i=1;i<101;i++)
				for(j=1;j<101;j++)
					sum+=hash[-(c*base[i]+d*base[j])+1000000];

			cout<<sum*16<<endl;				//X分正负,每个X有2个解,4个就有16种不同的解
		}

	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值