Babelfish Poj2503(STL map的使用)

Babelfish

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41561 Accepted: 17638

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

思路 : 存入map 查找输出0.0  裸裸STL 好害羞2333333.....

#include <iostream>
#include <map>
#include <cstdio>
#include <string>
using namespace std;

int main()
{
    char Key[66], Find[66];
    char str[66];
    map<string,string>mp;
    while (gets(str)&&str[0]!='\0') ///空行的控制
    {
        sscanf(str,"%s %s",Key,Find); ///sscanf按格式从a读串
        mp[Find]=Key;
    }
    while (gets(str)&&str[0]!='\0')
    {
        sscanf(str,"%s",Find);
        if (mp[Find]!="\0") ///int初始是0 string为'\0'
        {
            cout<<mp[Find]<<endl;
        }
        else
        {
            cout<<"eh"<<endl;
        }
///        map<string,string>::iterator(迭代器) x ; find()目测从头迭代
///        if (mp.find(Find)==mp.end())  ///到end时说明没有找到要找的元素
///        {
///            cout<<"eh"<<endl;
///        }
///        else
///        {
///            cout<<mp[Find]<<endl; ///map 类似二位数组
///        }
///注释方法也对
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值