PAT (Advanced Level) Practice 1002 A+B for Polynomials

1002 A+B for Polynomials

分数 25
作者 CHEN, Yue
单位 浙江大学

This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ … NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.
Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:

2 1 2.4 0 3.2 2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB

题目翻译:

1002.多项式A与B的和

这次,假设A和B是两个多项式,求A与B的和多项式。

输入

每个输入文件包含一个测试实例。每个实例有两行,每行包含一个多项式的信息: K N1 aN1 N2 aN2 … NK aNK,其中K为多项式中非0项的个数,Ni 和 aNi (i=1, 2, …, K) 分别为指数和系数。数的范围是1 <= K <= 10,0<= NK < … < N2 < N1 <=1000。

输出

对于每个测试实例,你需要在一行内输出A与B的和,格式与输入时相同。注意每行的结尾不能有多余的空格。小数精确到一位。

样例输入

2 1 2.4 0 3.2

2 2 1.5 1 0.5

样例输出

3 2 1.5 1 2.9 0 3.2

**题目解释:**上面提到的exponents和coefficients是在多项式(polynomial)中的指数次数和系数。如下图解释。
在这里插入图片描述

代码

#include <iostream>
#include <string>
#include <stdlib.h>
#include <cstdio>

using namespace std;

int main(){
    int k,exponent,count=0;
    double polynomials[1001]={0},coefficient;

    for (int i = 0; i < 2; i++) {
      cin>>k;
      while (k--) {
        cin>>exponent;
        cin>>coefficient;
        if (polynomials[exponent]==0) {
          polynomials[exponent]=coefficient;
        }else{
          polynomials[exponent]+=coefficient;
        }
      }
    }
    //注意一定要算完再计数因为可能进行加减后变为0而不在非0项中。
    for (int i = 0; i < 1001; i++) {
      if (polynomials[i]!=0) {
        count++;
      }
    }
    cout<<count;
    for (int i = 1000; i > -1; i--) {
      if (polynomials[i]!=0) {
        printf(" %d %.1f",i,polynomials[i]);
      }
    }
}

改进版使用map而不用遍历整个1001个数组位置。

#include <iostream>
#include <string>
#include <cstdio>
#include <map>

using namespace std;

int main(){
    int k,exponent;
    double coefficient;
    map<int,double> polynomials;

    for (int i = 0; i < 2; i++) {
      cin>>k;
      while (k--) {
        cin>>exponent;
        cin>>coefficient;
        if (polynomials[exponent]==0) {
          polynomials[exponent]=coefficient;
        }else{
          polynomials[exponent]+=coefficient;
          if (polynomials[exponent]==0) polynomials.erase(exponent);
        }
      }
    }
    cout<<polynomials.size();
    for (auto it=polynomials.end();it!=polynomials.begin();) {
      --it;
      printf(" %d %.1f",it->first,it->second);

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值