PAT (Advanced Level) Practice 1004 Counting Leaves

1004 Counting Leaves

分数 30
作者 CHEN, Yue
单位 浙江大学

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.
Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目翻译

背景:
族谱通常由系谱树来表示。你的工作是统计那些没有孩子的家庭成员总数。
输入格式:
每个输入文件包含一个测试用例。每一种情况都以包含以下内容:第一行有一个正整数N(0<N<100),它代表节点的总数,还有一个正整数M,代表不是叶节点的节点总数;然后接着有M行,每一行的格式都是 ID k ID[1] ID[2]…ID[K],其中第一个ID是一个两位数,代表一个给定的非叶节点,K是它的子节点的数量,后面是它的全部子节点的两位数ID序列。为了简单起见,规定根节点的ID为01。
输出格式:
对于每个测试用例,你应该从根节点开始,计算每一层(同辈)的没有孩子的家庭成员总数。结果必须在一行中输出,用空格隔开,并且在每行的末尾不能有额外的空格。示例示例表示一棵只有2个节点的树,其中01是根节点,02是唯一的子节点。因此在根01层上,有0个叶节点;下一层,有1个叶节点。所以应该在一行中输出0 1。

代码

#include <iostream>
#include <string>
#include <stdlib.h>
#include <vector>

using namespace std;

int maxLevel=0,level[100]={0};
vector<int> tree[100];

void dfs(int ID,int curLevel){
  if(maxLevel<curLevel)maxLevel=curLevel;
  if(tree[ID].size()>0){
    for(auto it:tree[ID]){
      dfs(it,curLevel+1);
    }
  }else level[curLevel]++;
}

int main(){
    int n,m;
    cin>>n>>m;
    while(m--){
      int ID,k;
      cin>>ID>>k;
      for (int i = 0; i < k; i++) {
        int temp;
        cin >> temp;
        tree[ID].emplace_back(temp);
      }
    }
    dfs(1,1);
    for (int i = 1; i <= maxLevel; i++) {
      if (i!=1) cout<<" ";
      cout << level[i];
    }

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值