PAT (Advanced Level) Practice 1004 Counting Leaves (30 分) 非 DFS / BFS 解法 凌宸1642

PAT (Advanced Level) Practice 1004 Counting Leaves (30 分) 非 DFS / BFS 解法 凌宸1642

题目描述:

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child…

译:一个家族的层次通常可以由一颗族谱树提现出来。你的任务就是找出那些没有孩子的家庭。


Input Specification (输入说明):

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

译:每个测试文件包含一个测试用例,每个测试用例开始的第一行包含一个整数 N (0<N<100),表示树中的结点个数,和一个整数 M (<N),表示非叶子结点的数目。接下来的 M 行,每行的格式如下

ID K ID[1] ID[2] ... ID[K]

ID 是一个两位数,表示给定的一个非叶子结点,K是它的孩子结点的数目,接下来的序列表示编号为 ID的孩字编号。为了简单起见,我们固定根结点的编号为 01。输入以 N 为 0 结束,这个样例不需处理。

Output Specification (输出说明):

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

译:对于每个测试用例,你应该从根结点开始,统计出对于每一层那些没有孩子的家庭成员的数量。数目必须在一行中输出,用空格隔开,并且行末没有多与的空格。

在样例中,表示一个拥有两个结点的树,01是根节点并且02 结点是它唯一的孩子结点。因此在第根节点这一层,叶子结点的数目为 0 ;在下一层,有1个叶子结点。所以我们应该在一行在一行中输出0 1


Sample Input (样例输入):

2 1
01 1 02

Sample Output (样例输出):

0 1

The Idea:

使用结构体来存储树,然后根据层数来排序,统计每层中没有孩子的结点数目。非 DFS 解法。

The Codes:

#include<bits/stdc++.h>
using namespace std ;
const int MAX = 110 ;
struct Node{
	int layer;
	vector<int> child ;
}tree[MAX];
int m , n , t , id , x ;
bool cmp(Node a , Node b){
	return a.layer < b.layer ; // 按层号有小到大排序
} 
vector<int> ans ;
int main(){
	cin >> n >> m ;
	for(int i = 0 ; i < m ; i ++){
		cin >> id >> t ;
		for(int j = 0 ; j < t ; j ++){
			cin >> x ;
			tree[id].child.push_back(x) ;
			//tree[x].layer = tree[id].layer + 1 ; // 测试点1 3过不了,因为输入第一行不一定是01 
		}
	}
	tree[1].layer = 1 ;
	for(int i = 1 ; i <= n ; i ++){
		for(int j = 0 ; j < tree[i].child.size() ; j ++){
			int x = tree[i].child[j] ;
			tree[x].layer = tree[i].layer + 1 ;
		}
	}
	sort(tree + 1 , tree + n + 1 , cmp );
	int max = tree[n].layer ;
	for(int i = 1 , j = 1 ; i <= max ; i ++){
		int cnt = 0 ;
		for(; j <= n ; j++){
			if(tree[j].layer > i) break ;
			else if(tree[j].child.size() == 0) cnt ++ ;
		}
		ans.push_back(cnt) ;
	}
	for(int i = 0 ; i < ans.size() ; i ++){
		cout << ans[i] <<((i == ans.size() -1)?'\n':' ' );
	}
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lingchen0522

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值