UVA 10391 Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is theconcatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line,in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, inalphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn
 

思路:

两种思路,合成和拆分。前者时间复杂度为O(n^2),超时。后者的为O(n*m),m小于n,VJ50ms,AC。
#include <iostream>
#include <cstdlib>
#include <string>
#include <map>

using namespace std;

const int maxn=120000+5;

int main()
{
    string word[maxn];
    map<string,bool> jud;
    int cnt=0;
    while(cin>>word[cnt])
        jud[word[cnt++]]=true;

    for(int i=0;i<cnt;i++)
    for(int j=0;j<(int)word[i].size()-1;j++)
    {
        string a=word[i].substr(0,j+1);
        if(!jud[a]) continue;
        string b=word[i].substr(j+1);
        if(!jud[b]) continue;
        cout<<word[i]<<endl;
        break;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值