成绩转换

Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
 

Input
输入数据有多组,每组占一行,由一个整数组成。
 

Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
 

Sample Input
  
  
56 67 100 123
 

Sample Output
  
  
E D A Score is error!
附上一份基本算法和另类解法
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
	int num;
	while(scanf("%d",&num)!=EOF) 
	{
		if(num>=90&&num<=100)
		{
			cout<<"A"<<endl;
		} 
		else if(num>=80&&num<=89)
		{
			cout<<"B"<<endl;
		} 
		else if(num>=70&&num<=79)
		{
			cout<<"C"<<endl;
		}
		else if(num>=60&&num<=69)
		{
			cout<<"D"<<endl;
		}  
		else if(num>=0&&num<=59)
		{
			cout<<"E"<<endl;
		} 
		else{
			cout<<"Score is error!"<<endl;
		}
		
	}	
}

/* HDU2004 成绩转换 */  
  
#include <stdio.h>  
  
int main(void)  
{  
    int score;  
    char convert[] = "EEEEEEDCBAA";  
  
    while(scanf("%d", &score) != EOF) {  
          if(score < 0 || score > 100)  
              printf("Score is error!\n");  
          else  
              printf("%c\n", convert[score/10]);  
    }  
  
    return 0;  
}  
该解法来自于:http://blog.csdn.net/tigerisland45/article/details/51758257



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值