PAT A1025

2019.1.26 11:27版本

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then Nranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 题意:

pat考试,给出每个考场的考生信息,对他们进行排序

难点:

难点:

① 存储准考证号

用 字符数组存储,最后比较字典序就用 strcmp 函数进行比较,strcmp(str1, str2) < 0,即为字典序小的排在前面

如果用 long long存储,则测试点3答案错误,因为若输入00000003,则输出则为3

② 对于每个考场数据的存储下标

设定一个整型变量 num,每输入完一个考场的考生(考生数为 k),就 num+=k;,然后每个考场当地排名也是从 num 开始到 num+k。

技巧:

① 第二次排名不需要存储,可以直接输出,就可以少1次 for 循环

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct Student{
	char id[13];
	int score;
	int lr; // 当地排名
	int kid; // 考场号
}stu[100000];
bool cmp(Student a, Student b){
	if(a.score != b.score)
		return a.score > b.score;
	else
		return strcmp(a.id, b.id) < 0;
}
int main(){
	int n;
	scanf("%d", &n);
	int num = 0;
	for(int i = 0; i < n; i++){
		int k;
		scanf("%d", &k);
		for(int j = num; j < k+num; j++){
			scanf("%s %d", stu[j].id, &stu[j].score);
			stu[j].kid = i+1;
		}
		sort(stu+num, stu+k+num, cmp);
		stu[num].lr = 1;
		for(int j = num+1; j < num+k; j++){
			if(stu[j].score == stu[j-1].score)
				stu[j].lr = stu[j-1].lr;
			else
				stu[j].lr = j+1-num;
		}		
		num = k + num;
	}
	sort(stu, stu+num, cmp);
	int r = 1;
	for(int i = 0; i < num; i++){
		if(i > 0 && stu[i].score != stu[i-1].score){
			r = i + 1;
		}
		printf("%s %d %d %d\n", stu[i].id, r, stu[i].kid, stu[i].lr);
		
	}	
	return 0;
}

2021.2.21版本

/**
 * 02.21 10:01
 * merge all the ranklists and generate the final rank
 * INPUT:
 * 第一行:N,考场位置
 * N行:每个以K开头,K:考生人数
 *      K行:注册号码,每个考生的总成绩
 * OUTPUT:
 * 第一行:打印出 考生总人数,然后打印出最终排行
 * 注册id、总排名、考场编号、考场排名
 *
 * 考察点:
 * 当前考场排名的实现?
**/
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn = 30005;

struct Student {
	char id[15]; // 这里不能用long long 存储,因如果输入000000003时,输出就是3了,所以要用字符数组存储
	int score;
	int kId; // 考场编号
	int finalRank; // 总排名
	int kRank; // 当前考场排名
} stu[maxn]; //本来是305,测试点4出现段错误,改成100*300=30010,变成答案错误

bool cmp(Student a, Student b) {
	return a.score > b.score;
}
bool cmp1(Student a, Student b) {
	if (a.finalRank != b.finalRank)
		return a.finalRank < b.finalRank;
	else
		return strcmp(a.id, b.id) < 0;
}

int main() {
	int n; // 考场个数
	scanf("%d", &n);
	int loc = 0; // 录入stu的下标用
	for (int i = 0; i < n; i++) { // 考场从 1~N 编号
		int k; // 当前考场的 考生人数
		scanf("%d", &k);
		for (int j = 0; j < k; j++) { // 录入当前考场信息
			char id[15];
			int score;
			scanf("%s %d", id, &score);
			strcpy(stu[loc + j].id,id);
			stu[loc + j].score = score;
			stu[loc + j].kId = i+1;
		}
		sort(stu + loc, stu + loc + k, cmp); // !!这里没有加stu,报错errorC2672_Sort_unchecked:未找到匹配的重载函数
		// 录入当前考场排名
		stu[loc].kRank = 1;
		for (int j = 1; j < k; j++) {
			if (stu[loc + j].score == stu[loc + j - 1].score) { //如果这个学生的成绩和它上一个学生成绩相同,则复制排名
				stu[loc + j].kRank = stu[loc + j - 1].kRank;
			}
			else { // 和上一个学生的排名不同,则就等于下标+1
				stu[loc + j].kRank = j + 1;
			}
		}
		loc += k;
	}
	// 进行总排名
	sort(stu, stu + loc, cmp);
	stu[0].finalRank = 1;
	for (int j = 1; j < loc; j++) {
		if (stu[j].score == stu[j - 1].score) { //如果这个学生的成绩和它上一个学生成绩相同,则复制排名
			stu[j].finalRank = stu[j - 1].finalRank;
		}
		else { // 和上一个学生的排名不同,则就等于下标+1
			stu[j].finalRank = j + 1;
		}
	}
	// 按照题意进行再排序,按照总排名升序,id升序
	// 如果不进行此操作,则【测试点1】答案错误
	sort(stu, stu + loc, cmp1);

	//printf("id         总排名   考场编号   当前考场排名\n");
	printf("%d\n", loc);
	for (int i = 0; i < loc; i++) {
		printf("%s %d %d %d\n", stu[i].id, stu[i].finalRank, stu[i].kId,
			stu[i].kRank);
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值