HPU DFS + BFS 专项练习A - Red and Black HDU - 1312

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

题意:有一个M*N的地板,分别有红地板‘#’和黑地板‘.’组成,一个人站在一块黑地板‘@’上并且只能走黑地板,问能走多少块黑地板;

思路:简单DFS:

下面附上模板:

#include<bits/stdc++.h>
using namespace std;
char mapp[105][105];
int vis[25][25];
int fx[4]={0,0,-1,1},fy[4]={1,-1,0,0};
int W,H;int ans=0;
void dfs(int x, int y)
{
	ans++;
	vis[x][y]=1;
	for(int i=0;i<4;i++)
	{
		int nx=x+fx[i];
		int ny=y+fy[i];
		if(nx>=0 && ny>=0 && nx<H && ny<W && !vis[nx][ny] && mapp[nx][ny]=='.')
		{
			//printf("%d %d\n",nx,ny);
			dfs(nx,ny);
		}
	}
}
int main()
{
	while(~scanf("%d %d",&W,&H),W){
		int sx,sy;ans=0;int flag=0;
		memset(vis,0,sizeof(vis));
		for(int i=0;i<H;i++)
			scanf("%s",mapp[i]);
		for(int i=0;i<H;i++)
		{
			for(int j=0;j<W;j++)
				if(!vis[i][j]&&mapp[i][j]=='@')
				{
					sy=j;
					sx=i;
					flag=1;
					break;
				}
			if(flag) break;
		}
		//printf("%d %d\n",sx,sy);
		dfs(sx,sy);
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值