关于BFS搜索的思想, 最简单的水题,不过深有体会啊。

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and HW and H are the numbers of tiles in the x- and y- directions, respectively.W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
 
相当于遍历一个二维数组,然后在能走到的范围里面计数能到达的位置。 很简单,就不停的递归就可以了。
 
 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
using namespace std;
int cont;
 int M,N,i,j,k,t;
char a[25][25];
bool b[25][25];
void bfs(int i ,int j)
{
    if(i>0&&a[i-1][j]=='.'&&b[i-1][j]==0)
    {  if(b[i-1][j]==0)
        cont++;
        b[i-1][j]=1;
        bfs(i-1,j);
    }
    if(j>0&&a[i][j-1]=='.'&&b[i][j-1]==0)
    {
        if(b[i][j-1]==0)
        cont++;
        b[i][j-1]=1;
        bfs(i,j-1);
    }
    if(i<M-1&&a[i+1][j]=='.'&&b[i+1][j]==0)
    {
        if(b[i+1][j]==0)
        cont++;
        b[i+1][j]=1;
        bfs(i+1,j);
    }
    if(j<N-1&&a[i][j+1]=='.'&b[i][j+1]==0)
    {
        if(b[i][j+1]==0)
        cont++;
        b[i][j+1]=1;


        bfs(i,j+1);
    }
}
int main()
{
   while(scanf("%d%d",&N,&M)!=EOF)
   {
       if(M==0&&N==0)
        break;
       cont=1;
       getchar();
       memset(b,0,sizeof(b));
       for(i=0;i<M;i++)
        {
      for(j=0;j<N;j++)
                {
                    scanf("%c",&a[i][j]);
                    if(a[i][j]=='@')
                    {
                        k=i;
                        t=j;
                        b[i][j]=1;
              }
         }
              getchar();
        }
        bfs(k,t);
        printf("%d\n",cont);
   }
	return 0;
}

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值