河南省多校连萌(五) Problem B: 就是签到题XD

Submit: 545  Solved: 85

SubmitWeb Board
Description
In mathematics, we suppose that f(1)=1, f(i)-f(i-1)=1/i, (2<=i<=n)

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing an integer n (2 ≤ n ≤10^7).

Output
For each case, print the case number and the value of f(n). The answer should be rounded to 10 decimal places.

Sample Input
3
2
3
4
Sample Output
Case 1: 1.5000000000
Case 2: 1.8333333333
Case 3: 2.0833333333
HINT


题意:有一个数列每一项的值都是前面的数加上其下标分之一。。。。问第n项的值;

思路:由于值比较大,所以采取分段打表的方式,每100项打一次表并以此为基点算值就可以了;

下面附上代码:

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
const int M=1e7+10;
double a[100010]; 
void init()
{
	double ans=1.0;	
	for(int i=2;i<=M;i++)
	{
		ans+=1/double(i);
		if(i%100==0)
			a[i/100]=ans;
	}	
} 
int main()
{
	int T,k=0,n;
	cin>>T;
	init(); 
	while(T--)
	{
		cin>>n;
		int l=n/100;
		double ans=a[l];
		for(int i=l*100+1;i<=n;i++)
			ans+=1/double(i);
		printf("Case %d: %.10lf\n",++k,ans); 
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值