【题解】LightOJ1234 Harmonic Number 数学知识+打表

23 篇文章 0 订阅
5 篇文章 0 订阅

题目链接
这里写图片描述

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139


公式数据大的时候误差比较小,小数据打表大数据套公式

#include<cstdio>
#include<cmath>
#include<iostream>
#include<iomanip>
using namespace std;
const int N=1e6;
double a[N+10];
int main()
{
    //freopen("in.txt","r",stdin);
    int t,n,i;
    scanf("%d",&t);
    for(i=1;i<=N;i++)a[i]=a[i-1]+1.0/i;
    for(int ca=1;ca<=t;ca++)
    {
        printf("Case %d: ",ca);
        scanf("%d",&n);
        double ans;
        if(n<=N)ans=a[n];
        else ans=log(n)+0.5772156649+1.0/(2.0*n);
        printf("%.10f\n",ans);
    }
    return 0;
}

总结

考察公式

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值