transaction transaction transaction (SPFA)

题目:https://vjudge.net/contest/241123#problem/C

Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell. 
As we know, the price of this book was different in each city. It is aiai yuanyuan in iittcity. Kelukin will take taxi, whose price is 11yuanyuan per km and this fare cannot be ignored. 
There are n−1n−1 roads connecting nn cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get. 

Input

The first line contains an integer TT (1≤T≤101≤T≤10) , the number of test cases. 
For each test case: 
first line contains an integer nn (2≤n≤1000002≤n≤100000) means the number of cities; 
second line contains nn numbers, the iithth number means the prices in iithth city; (1≤Price≤10000)(1≤Price≤10000) 
then follows n−1n−1 lines, each contains three numbers xx, yy and zz which means there exists a road between xx and yy, the distance is zzkmkm (1≤z≤1000)(1≤z≤1000). 

Output

For each test case, output a single number in a line: the maximum money he can get. 

Sample Input

1  
4  
10 40 15 30  
1 2 30
1 3 2
3 4 10

Sample Output

8

 

最短路的题目,将买书和卖书的历任算到路径权值中,对每一个点用一次SPFA,最后求出所有点距离最大值就可以。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
struct Edge
{
    int u,v,dist,next;
};
Edge edge[maxn*2];
int head[maxn];
int n;
int Edge_Num;//边数目,切记
int dist[maxn];
void addedge(int u,int v,int dist)
{
    edge[Edge_Num].u=u;
    edge[Edge_Num].v=v;
    edge[Edge_Num].dist=dist;
    edge[Edge_Num].next=head[u];
    head[u]=Edge_Num++;
}
void SPFA(int start)
{
    queue<int>que;
    que.push(start);
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            if(dist[edge[i].v]<dist[u]+edge[i].dist)//利润要大于
            {
                dist[edge[i].v]=dist[u]+edge[i].dist;
                que.push(edge[i].v);
            }
        }
    }
}
int price[maxn];
int main()
{
    int t,u,v,dis;
    scanf("%d",&t);
    while(t--)
    {
        memset(dist,0,sizeof(dist));//初始化
        memset(head,-1,sizeof(head));//初始化
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&price[i]);
            Edge_Num=0;
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%d",&u,&v,&dis);
            addedge(u,v,-dis-price[u]+price[v]);
            addedge(v,u,-dis-price[v]+price[u]);
        }
        for(int i=1;i<=n;i++)
        {
            SPFA(i);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            ans=max(ans,dist[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值