AcWing851- spfa求最短路
题目描述
给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环, 边权可能为负数。
请你求出 1 号点到 n 号点的最短距离,如果无法从 1 号点走到 n 号点,则输出 impossible
。
数据保证不存在负权回路。
输入格式
第一行包含整数 n 和 m。
接下来 m 行每行包含三个整数 x,y,z,表示存在一条从点 x 到点 y 的有向边,边长为 z。
输出格式
输出一个整数,表示 1 号点到 n 号点的最短距离。
如果路径不存在,则输出 impossible
。
数据范围
1≤n,m≤10^5
图中涉及边长绝对值均不超过 10000。
输入样例:
3 3
1 2 5
2 3 -3
1 3 4
输出样例:
2
题解
package acWing851;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.LinkedList;
import java.util.Queue;
class Pair{
int x,y;
public Pair(int x,int y){
this.x = x;
this.y = y;
}
}
public class Main {
static int M = 1<<30;
static int N = 1000010;
static int m,n;
static int h[] = new int[N],e[] = new int[N],ne[] = new int[N],w[] = new int[N],idx=0;
static int dist[] = new int[N];
static Boolean st[] = new Boolean[N];
static void add(int a,int b,int c){
e[idx] = b;w[idx] = c;ne[idx] = h[a];h[a] = idx++;
}
static void spfa(){
Queue<Pair> q = new LinkedList<>();
Arrays.fill(dist, M);
Arrays.fill(st, false);
dist[1]=0;
q.add(new Pair(1,0));
st[1] = true;
while(!q.isEmpty()){
Pair p = q.poll();
int t = p.x;
st[t] = false;
for(int i=h[t];i!=-1;i=ne[i]){
int j = e[i];
if(dist[j]>dist[t]+w[i]){
dist[j] = dist[t] +w[i];
if(!st[j]){
st[j] = true;
q.add(new Pair(j,dist[j]));
}
}
}
}
System.out.println(dist[n]==M ? "impossible":dist[n]);
}
public static void main(String[] args) throws IOException {
BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
String str[] = bf.readLine().split(" ");
n = Integer.parseInt(str[0]);m = Integer.parseInt(str[1]);
Arrays.fill(h,-1);
while(m-->0){
str = bf.readLine().split(" ");
int a = Integer.parseInt(str[0]),b = Integer.parseInt(str[1]),c = Integer.parseInt(str[2]);
add(a,b,c);
}
spfa();
bf.close();
}
}