AcWing859-Kruskal算法求最小生成树(java实现)

AcWing859-Kruskal算法求最小生成树

题目描述

给定一个 n 个点 m 条边的无向图,图中可能存在重边和自环,边权可能为负数。

求最小生成树的树边权重之和,如果最小生成树不存在则输出 impossible

给定一张边带权的无向图 G=(V,E),其中 V 表示图中点的集合,E 表示图中边的集合,n=|V|,m=|E|。

由 V 中的全部 n 个顶点和 E 中 n−1 条边构成的无向连通子图被称为 G 的一棵生成树,其中边的权值之和最小的生成树被称为无向图 G 的最小生成树。

输入格式

第一行包含两个整数 n 和 m。

接下来 m 行,每行包含三个整数 u,v,w,表示点 u 和点 v 之间存在一条权值为 w 的边。

输出格式

共一行,若存在最小生成树,则输出一个整数,表示最小生成树的树边权重之和,如果最小生成树不存在则输出 impossible

数据范围

1≤n≤10^5,
1≤m≤2∗10^5,
图中涉及边的边权的绝对值均不超过 1000。

输入样例:

4 5
1 2 1
1 3 2
1 4 3
2 3 2
3 4 4

输出样例:

6

题解

package acWing859;

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.Arrays;

class Edge implements Comparable<Edge>{
	int a,b,w;
	public Edge(int a,int b,int w) {
		this.a = a;
		this.b = b;
		this.w = w;
	}
	@Override
	public int compareTo(Edge o) {
		return this.w - o.w;
	}
}
public class Main {
	
	static int N = 100010,M = 200010,INF = (int)0x3f3f3f3f;
	static int n,m;
	static Edge edges[] = new Edge[M];
	static int p[] = new int[N];
	
	static int find(int x) {
		if(p[x] != x) {
			p[x] = find(p[x]);
		}
		return p[x];
	}
	
	static int kruskal() {
		Arrays.sort(edges,0,m);
		for(int i=1;i<=n;i++) {
			p[i] = i;
		}
		int res = 0,cnt = 0;
		for(int i=0;i<m;i++) {
			int a = edges[i].a,b = edges[i].b,w = edges[i].w;
			a = find(a);b = find(b);
			if(a!=b) {
				p[a] = b;
				res += w;
				cnt ++;
			}
		}
		if(cnt<n-1) {
			return INF;
		}else {
			return res;
		}
	}
	
	public static void main(String[] args) throws Exception{
		BufferedReader  bf = new BufferedReader(new InputStreamReader(System.in));
		String str[] = bf.readLine().split(" ");
		n = Integer.parseInt(str[0]);m = Integer.parseInt(str[1]);
		for (int i = 0; i < m; i ++ ) {
			str = bf.readLine().split(" ");
			int a = Integer.parseInt(str[0]),b = Integer.parseInt(str[1]),c = Integer.parseInt(str[2]);
			edges[i] = new Edge(a,b,c);
		}
		bf.close();
		int t = kruskal();
		if(t == INF) {
			System.out.println("impossible");
		}else {
			System.out.println(t);
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

杜柠函

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值